Blend poses and inherited transform

I’m having a persistent issue that I can’t seem to figure out when trying to blend poses for multiple skeletal meshes on one character.
The location of the blended “root” bone seems to inherit from the base pose’s “tail”, and it’s offsetting the whole limb by whatever distance. Is there a way to set the blended pose to its world location, or default, or something that will force it to stop inheriting the previous bone’s “tail” location? There’s a checkbox to use mesh space rotation and scale, but not location. All the skeletal meshes use the same master skeleton, and I’m just using the “SetMasterPoseComponent” node inside the playerBP.

I managed to get it into a workable state via some kludgy over-engineering with inverting world vectors into transform bone nodes in the animBP. If anyone has a better/easier/more efficient method, I’d love to hear it, I feel like I’m missing something fundamental here, but maybe that’s just wishful thinking.