Download

Blend in/out time issue

Hi everyone, I have a problem with an animation montage. When i play the montage via blueprint the animation seems “compressed”. I mean it seems like the start and the end are blended too much. So i set Blend in and out time values in the montage to 0 but nothing changed. It’s strange cause the animation duration is about 1.5 sec and also a Blend time of .25 shouldn’t be a problem.
So where could be the problem?

EDIT: It’s an attack animation montage and i noticed that if I play it via key input it works well but when I attach the weapon to the skeleton socket the problem is there. I have no idea.

Attaching a weapon or anything at all should have no bearing on animations.

Are you maybe using a physical animation profile or something similar that would cause the animation to react to the attached object(s) ?

Thanks for answering. I checked but i didn’t do anything like that. I have a simple first person arms skeletal mesh and an animation montage with an animation in it. I thought the problem was in the montage but I tried it with a direct key input and it works perfectly. I tried it the same way but with an actor (weapon) spawned and attached to the hand socket and it becomes wrong the way I said before. I really don’t understand why this is happening.