Blank screen with iOS8 and 4.3

On my iPadMini Retina running iOS8 I get just a blank greyish screen after the launch image when running a fresh ‘First Person Template’ build. I also tried the vehicle template and I get the same issue. Both work fine on my iPhone5s running iOS7. Unreal 4.2.1 was also showing the same issue - but since Metal (an iOS8 only feature) support is now in 4.3, I thought it would be fixed. Anything I can try or do to fix this?

Can you please try MobileTemple? Some maps are having issues, we’re looking into it.

I downloaded the latest MobileTemple and ran it. Looks better - no ‘blank’ screen. But it does appear to be drawn in Portrait instead of landscape. Here’s a snap (scaled down from 2048x1536):
Screenshot 2014.07.17 11.22.25.png

I also noticed that the virtual onscreen gamepads are missing. This is all with the latest iOS8 iPadMini Beta3 and Xcode 6 Beta3.

Hi aking,

Can you please post this to the answerhub at http://answers.unrealengine.com so we can track this? Thank you!

Please post the link to the question here after you ask it; I can also tell you we’re working around a driver bug right now which is causing the grey screens.

do you have the “answers” link? i have the same problem here

I changed the orientation to “portrait” and it worked. I guest it’s a problem with landscape settings.

Hey guys, we’re working to track this down; it’s an issue with the pow() function when calculating fog; can you try modifying the fog component in your map? Alternatively you can modify BasePassForForwardShadingCommon.usf locally and change #define USE_VERTEX_FOG to 0 (but this will remove all fog).
We’re still trying to get a good workaround! The one suggested by Apple has perf implications :frowning:

Perfect, TNX

As for the portrait vs landscape thing, I did see that once but I think it was only when I was compiling directly on the Mac (compiling from Windows was fine). Not sure why it would make a difference. I thought it was some strange one off issue. I just ran MobileTemple (compiled from and cooked with Windows), and it ran fine in Landscape.

Apple did change some things in IOS8 that made me write some version checking code in the landscape handling code.

Looks like I’ll have to go back to Mac building and see if I can repro again!

One question, when it boots up, does it say it’s in LANDSCAPE or PORTRAIT mode, when you had the .plist in Landscape?
Josh

can confirm bug here also:
XCode 6, beta 4
iOS8, beta 4
device: iPhone5
UE4: 4.3
OS: Mac OSX 10.10 beta 4
when running it presents unreal engine 4 logo correctly as it’s in landscape mode, but the scene is rendered wrong as portrait.
this is .plist I am using (only bundle id removed)

This looks the same for me on an iPad4 in Landscape mode, it happens when deploying from a Mac aswell as from Windows.

Ok guys, final fix went into perforce changelist 2228471; you can make the change locally by replacing on UE4/Engine/Shaders/HeightFogCommon.usf:
[FONT=Courier New] // Setup a cosine lobe around the light direction to approximate inscattering from the directional light off of the ambient haze
half3 DirectionalLightInscattering = DirectionalInscatteringColor.xyz * pow(saturate(dot(CameraToReceiverNormalized, InscatteringLightDirection.xyz)), DirectionalInscatteringColor.w);

with
[FONT=Courier New] // Setup a cosine lobe around the light direction to approximate inscattering from the directional light off of the ambient haze;
// clamp to avoid issues on some platforms (Could’ve used ClampedPow(), but we want the dot to be 0…1)
half3 DirectionalLightInscattering = DirectionalInscatteringColor.xyz * pow(saturate(dot(CameraToReceiverNormalized, InscatteringLightDirection.xyz)), clamp(DirectionalInscatteringColor.w, 0.000001f, 1.0));

[EDIT] Here’s the change: https://github.com/EpicGames/UnrealEngine/commit/8a2b4f98668200fd852b2c220fa1ceb1d0a02454

I just ran MobileTemple in beta4, and it’s landscape properly (built/cooked with Mac and with Windows). Maybe something changed in beta4, not sure. I can’t repro the problem any more, however.

If someone tries beta4 and still has it happen, let me know.

Josh

I just had this happen. I cannot launch from the editor at all - its complaining about certificates


LogPlayLevel:Display: env: Code Sign error: Multiple matching codesigning identities found: Multiple codesigning identities (i.e. certificate and private key pairs) matching ???iPhone Developer??? were found.

But if I open the Xcode Project and run it form there it runs fine but ends up with the portrait rendering in landscape, I also don’t get any virtual sticks

OSX 10.10 b4, ios8 b4, UE 4.3.1

I still have the same issue with the landscape mode. Windows 7, iOS8 beta 4, UE 4.3.1, iPad4 . Portrait mode runs fine and the splash screen is shown correctly aswell.
There is still something seriously wrong with iOS8 like all UE3/UDK games crashing on launch aswell. This looks more like a problem on Apple’s side to me.

Okay, I finally reprod it. It only happens if you compile with Xcode 5 (ios7) and run on ios8. I have been using Xode6 for so long, I haven’t seen it.

Anyway, I’m on it now!!

And yes, we know what’s up with the UE3 issue. The next UDK release will have it fixed, still figuring out what to do with the shipped games on app store. I’ll try to keep this thread posted :slight_smile:

Awesome, thanks! :slight_smile:

Fixed it!

https://github.com/EpicGames/UnrealEngine/commit/77eb4e9fc4837d7842a72040e1b693166cf15aca

Josh

Thanks Josh, good news :slight_smile: