blacks spots on mesh

Where those dark area come from ?
They appear in all the meshes I imported from the same blender file and do not disapear if I change the material. They are sticking to the mesh. So it’s not a light or a material issue, it’s a mesh problem.

1 Like

I think you probably have a normals problem.

Have you looked at them in Blender?

All blue outside, all red inside. I recomputed all
normals to outside before re-exporting the mesh, no change in unreal.
The problem is related to light complexity :

Same problem after applying a remesh modifier in blender.

Are you building light?

It could also be reflective spots on the mesh?

I already rebuilt light only and all levels too but the problem is not there because it’s in the asset editor viewport too. The last screenshot above is from the mesh asset editor, not the scene viewport.
The problem disapear when I disable nanite support on the mesh.

I don’t understand why light complexity view mode override normal mode.

I have deleted all vertices with normal lenght < 0.9 in blender, triangulated all faces, recalculated normals to outside, deleted inside faces, created a new mesh but none solved the problem.

Ah, is it this?

Not really a solution as it require to remove raytracing but it works. Thank you.

1 Like

Yes, lighting stuff is going to be a hinky, I’m guessing, while Lumen settles in.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.