Blackboard Key Selector can't find key anymore

I tried searching for any earlier reports but couldn’t find any so hopefully this has yet to be reported.

Getting a key with a blackboard key selector now seems to be returning a null value. Just to be sure I tried this out with a currently working blueprint. So here’s what I did:

  1. Ran blueprint with old code. selector found key without any problems (image 1).
  2. Changed name of key selector variable to “Target1”
  3. Compiled
  4. Changed name of key selector back to “Target”
  5. Compiled
  6. Ran blueprint again. key selector could no longer find key (image 2)

Hi TheYawningWhale,

I wasn’t able to reproduce this in 4.9.2, but I may not have enough details to accurately recreate your setup so I have a few questions:

  • Are you able to reproduce this behavior in a new project, or only your current project?
  • How and where are you setting Target variable?
  • Does this only happen in this particular Decorator, or can you reproduce in another decorator or any other BT class?

If you’re able to recreate this in a small test project, please upload it someplace like Google Drive or Dropbox for me and get me a download link so I can take a look. Thanks!

I just tried reproducing this in a fresh project but was also unable to. After tidying up and fixing up redirectors in my original project issue seem to have vanished.

There were probably some old files still lying around messing about. Apologies for false report!

No worries, glad you got it working in your project. I’ll resolve this post for now, but let us know if issue reappears. Thanks!

Hi again!

Disregard what I wrote earlier, I manged to break it again in a fresh project =P

Where would you like project uploaded? I Used third person template so it’s fairly large. If you’d like I could, instead of uploading project, record a video of process and submit.

Attached is a video of issue appearing in freshly created project.

link text

I uploaded project at

Easiest way to reproduce is just to follow video i attached earlier.

If you have any more questions feel free to ask!

Hi, this link doesn’t work for me. Can you try using a service like Google Drive or Dropbox?

It looks like it’s still working in your video, it’s just not showing up in tooltip. Is bug simply a problem with tooltip, or is this affecting functionality of key variable?

Hm, link is stone dead indeed, strange. Anyways, here’s a dropbox link to same file: Dropbox - Error - Simplify your life

Unfortunately, functionality suffers. In project there’s a simple patrol set up for an AI character. I should’ve shown it in video now that I think about it, but basically patrol works as long as key variable is properly called but after recompile AI stops functioning.

Hey TheYawningWhale,

Thanks for test project!

I see behavior you were describing, and was able to reproduce it in a smaller project in 4.9.2 as well as our internal build. It looks like changing name of variable inside Task updates Task node inside Behavior Tree and sets it to “none”, for which I have entered a bug report (UE-21822). I also discovered that changing name of a Key in Blackboard will show similar behavior with any nodes referencing it in Behavior Tree, updating references to “invalid”, which I have entered in a separate bug report (UE-21817). In both cases, clicking affected node in Behavior Tree updates “none” or “invalid” reference to first Key listed in Blackboard, which I noted in both bug reports.

I’ll update this post when I see any fixes come in for these. In meantime, if making changes to variables or Blackboard Keys that are used in Behavior Tree, make sure you click affected nodes in BT and double-check that it references desired Key, and it should resolve any issues in functionality.

Thanks again!

This is still not fixed? is any workaround? For me, i can even create complete new variables and it does not help.