Download

black viewport after importing anything with datasmith

whatever I export from 3ds max 2019 into ue 4.22 with datasmith turns my viewport black. everything is black, no matter what template I’m using. If I have a post process volume I have to crank exposure compensation to the max to see anything and it’s still dark. but if I don’t have it, I have to turn off game settings from viewport exposure control, and when I press play, the game is all black.

what’s going on?

Check your world Outliner, you should see another post process volume, usually named GlobalProcess (or something like that, just type “global” in the outliner) and delete it or disable it. Alternatively, before exporting from 3Ds Max, disable your exposure controls. The Global Process volume that is imported from the datasmith importer is because of enabled exposure controls in 3Ds Max. At least that’s what I think it is, because I notice that when I export and have exposure controls disabled I dont get the extra post process volume imported in UE4.

Yes, since 4.22 we are carrying that information more correctly. (and sometimes, if 3ds max isn’t used for rendering, the max exposure can be ON without being noticed - which we carry over anyways).

right, exposure usually overwrites it and you gets dark environment

@dvenov i love you man ! you solved me a big head ache and im back on schedule! god bless you :smiley: