Black screen when launch GearVr 4.12.1

link text
Hi there, this is really driving me crazy, before I was able at a first time to deploy a default game to my Samsung Galaxy S6 Edge, now, I’m getting a black screen with a little x at the top left corner, I read everything about it and I tried the following.
Check the ossig file to be in the correct folder. ( then checked inside the APK if it was present and it is )
Disable the GearVr plugin in the UE4 plugin page
Disable HDR
Packaging externally with no use of the launch feature
Packaging with Launch Feature
I’m using ETC2 compression method as listed in the guide.
Please help!

No, enable GearVr on Plugins page, disable everything else in that section… you can leave on Occulus Library it wont hurt anything, actually may help depending on what your doing.

Also in the Android section where you set you build name etc… make sure apk is set to 19 and also down below enable build for gearvr option…

And also make sure you set your default map and startup map in Maps and Modes in project settings… also make sure your character is set… ie: Game mode, player, controller etc. And have either your player start or custom character set in world set to player 0.

hope something in there helps ya man.

Also just go over this again to see if ya missed a step or two… wont hurt in long run…

https://docs.unrealengine.com/latest/INT/Platforms/GearVR/index.html

Just saw this… maybe this is an answer as well… Black screen in every map except PIE mode - Platform & Builds - Unreal Engine Forums he figured it out, a game instance was messing him up…