Download

Black Screen on new GearVR & Galaxy S8+ | UE 4.18.0

I´m trying to get a basic VR onto the new GearVR with Samsung Galaxy S8+. I followed all instructions for Android setup, but all I get is a blank screen after I put the phone into the HMD. Four finger touch would do anything.

I´ve tried:

  • open a Blank project BP, First Person BP, Third Person BP and the the GearVRCameraSetup
  • starting the Editor from Launcher or directly open the project
  • building another Engine from source and create a new project from there
  • tried different options (on/off) in project settings, such as: Full Rebuild, Mobile HDR, OpenGL ES2, ES3.1, Vulkan
  • different SDK Versions (although only 24 seems to work for S8+)

I´ve deployed the app through the Project Launcher since using the Launch Button causes the Editor to crash immediately without a chance to get any logs (but that´s another issue).
The app will successfully install on the phone and start but seems to stuck with just black screen.

Unfortunately I don´t have another type of phone to test it there. I have attached the Project Settings and logs.

Hi, i’m developing an app on S8 and s8+ too.

I’m not an expert but be sure to use the correct osig file, also mine minimum SDK is 19 and maximum is 21. NDK API level is set to 19.
Any error on build log?

Are you using any material that doesn’t works on mobile?
Didi you try to download the project from here to see if it’s working?

https://docs.unrealengine.com/latest/INT/Platforms/GearVR/QuickStart/3/index.html

Hi, many thanks!

But I solved that problem finally.

  1. I had the wrong SDKs installed. For me it´s working with android-24. Since then I haven`t tried a lower version yet.
  2. ASTC packaging didn´t work either. But I got something on the screen by using ETC2. Since 4.18.1 this problem doesn`t exist anymore.

Cool, nice to hear that.