- Black Materials on Multiple Model Import

Hey all,

If I attempt to import multiple SRTs that share materials into the same folder in the content browser, the first model will import correctly, but the remaining trees will import with missing materials. This happens whether I import them simultaneously or sequentially. I can import multiple trees into the same folder that do not share any materials. I can also import the trees into individual folders and then merge the content of those folders into one without any issues. It appears to only be an issue during the import process with trees that share materials. The import process works fine in 4.7.6. But it appears to have been broken in 4.8. I’ve got both 4.8.3 and 4.9.1 and the import is broken in both of those versions.

You guys should have access to whatever trees you need, but I can get you models that share materials if need be.

Best Regards,

Hi ,

Currently I only have access to the free assets (Broadleaf, Palm, Conifer, Euterpe) from the site. I’ve tried making a copy of the Broadleaf and importing the original and the copy, but I’m not seeing what you’re describing. This could be just a flaw in how I’m doing it though or if it can be done with these meshes/materials.

I do have some questions with what may be going on:

  • When you import are you using the default settings in the import options?
  • When you say that the materials are missing, is this just the material is not imported or that it’s not assigned to the mesh, but all the material IDs are still present?

If you need to share the trees to get the repro you can share them privately here in a message to me on the forums: https://forums.unrealengine.com/private.php?do=newpm&u=4894

If it can be easily done with the trees I currently have please let me know the repro to do so and I’ll give it a test.

Let me know.


Hey Tim,

  • When you import are you using the default settings in the import options?


  • When you say that the materials are missing, is this just the material is not imported or that it’s not assigned to the mesh, but all the material IDs are still present?

I misspoke. The materials are not missing,. The textures are. So the materials are present in the content browser, but some of the materials are black because the textures are missing.

Sorry for the confusion, that was my fault. I’ll send you a dropbox link to some models so you can test it easily.


I’m seeing a similar issue on 4.9.2: I’m trying to import a single tree, the Broadleaf_mobile from the free examples. The mesh ends up being black and the log has a few errors like this:
Error: Texture import failed
LogEditorFactories:Warning: – import failed
LogStreaming:Warning: Failed to read file ‘/Broadleaf_Mobile_Atlas.tga’ error.
LogSpeedTreeImport:Warning: Unable to find Texture file /Broadleaf_Mobile_Atlas.tga

Materials are created and assigned but they do not contain any texture sampler nodes. I manually imported those textures and then reimported the .srt file but it still fails to import or reference those textures.

Having a similar problem with imports coming in black. The materials are all messed up. Everything is there (textures, meshes,materials) but the materials are all missing textures. This can be fixed manually but it’s a bit tedious.

I’m not really sure how to fix it in some materials that use node-magic rather than simple textures plugged in :\ One in particular is set to use a mask but I’m not sure what they had used to mask the opacity.

This has been resolved with CL-2848895 and will be included in the 4.11 release. This should be testable in the next 4.11 Preview 5 release.

Thank you!


I still have this issue … even with 4.11 release

Using the sample assets I have available to test, I’m not seeing the same issue that was reported with previous versions.

If you have any additional information, such as the assets you’re using or additional repro steps. Any screenshots of the results may be helpful as well.

Thank you!

Not sure if an answer was ever found for this or not but…
I had just run into the same issue and had been trying to figure out a work around for it. I’m currently using version 4.10. All new trees that I have been trying to create had no textures and the materials were all black, or the billboards were all white.
I got them to import again correctly by, instead of just saving the tree as usual using “Save” or “Save as…”, I used “Save as with assets…” and that imported all of the textures like it had been in previous versions of .
Hope that works for anybody who is still having issues with that.

I had the exact same problem until I changed the file type of the textures that the ST7Compiler was generating. I’m a new user, so it took me some trial and error. The file type was set to “DDS” by default. Importing the resulting .srt file into UE4 gave me all-black materials and no textures.When I changed the file type to “TGA” it worked fine. You can specify other formats to suit your needs. Also, don’t forget to choose your appropriate platform (DirectX 11, OpenGL, Xbox One, etc.). I hope this helps someone!