Download

Black Flickering Problem

Hey all. I’ve been having an issue in Unreal for a while that I can’t seem to fix. In the editor, some of my meshes have this ugly flickering effect, as seen in this video:

It almost looks like z-fighting except there’s only one instance of the model which has no overlapping faces.
Opening the same mesh in other software does not present an issue (Maya, Marmoset Toolbag, Substance Painter etc)

I’ve tried cleaning up the mesh, exporting it as an OBJ, re-exporting it etc. Sometimes, re-exporting will shift the problem to another area of the model but never removes the issue entirely.
This has happened to a bunch of my models in the last year or so.

It is worth noting that this DOESN’T happen in the asset properties/preview window, only in the level/viewport.

Can anyone help? Thank you so much for reading :slight_smile:

It’s definitely Z-fighting, nothing else causes that effect, you’ll have to figure out how there’s two meshes there

Yes, it looks like Z-fighting to me also. Maybe you don’t see it in the other software due to normal direction and visibility.

I’m having the same or a similar problem in version 4.15. Assets that worked fine in previous versions have this flickering now. It is not z fighting. There is no doubled up face or any other face near by. I could reduce or eliminate the problem in another mesh (table legs) by adding edges near the end of the long face.

I have carried some of these meshes through various versions and they always rendered fine. it seem to happen with long and thin faces now. Is there an engine change that might have caused this? - I also haven’t tried 4.16 yet.

Here is an example. The black flickering face is long and thin. There is definitely no other face overlapping or close by. (ignore the weird faces near the camera. I am clipping through another mesh)

HighresScreenshot00035.jpg

Well I could get rid of the flickering by adding 1 more edge towards each corner of the mesh and rebaking it. Smoothing groups were a bit messy too. Has the renderer changed so that it is less forgiving when you create your mesh a bit messy?

Go into the parent material and under usage options make sure you have set on skeletal/static instances, I had this same issue that popped up when I moved over to 4.15.

thanks Cr1lord, I checked the flags and not all were set. However - It is still there in 4.16 and I think it has to do with how I set the smoothing groups for the low and high poly model. And also it just doesn’t seem to like long and very thin polygons.

I had this problem with an airvent in the past. For me it was not exactly z fighting. For example with my vent i had geometry for outside and inside of the airvent. Both 1 sides facing opposit directions. Though the vertices and polygons were in teh same position. Now theoretically the other side should be back faced cull but for wathever reason i got the black geometry you are experencing. To fix it i just selected all my verts and did a merge vert by a very low threshhold… then reexpor/ reimported it…for whatever reason it fixed the problem.

That looks like it may be an issue with n-gons when it exported, so one of the polygons might be overlapping partly within itself.