Black flickering in viewport and in game

I suddenly have this weird black flickering on a level I am working on. Certain parts of the map disappear for a second or two along with the black flickering It seems to only occur on certain parts of the map. I tried uninstalling my old graphics card driver and installing the previous version but that did not fix things. I havn’t had any map or lighting errors either. This occurs in editor as well as in packaged project, and play in viewport. Here are a few pictures.

Hello lowercase15,

Can you reproduce this in a blank project and provide me with step so I can visualize the issue on my end?

The screenshot you provided does not give me much context in regards to what you are doing and what could be causing the issue.


Either you have something corrupted or some overlapping face in your mesh. Is the issue with the mesh or the terrain?
If the issue is the same in another new project, it’s probably your mesh. If the issue with your terrain, does it persist with a newly created terrain?

Hi Andrew,
I am unable to reproduce this in a blank project.Here are some videos of it happening. Doesnt seem to be happening anywhere else on the map except for the section in the videos.

it looks like something is corrupted, just migrate to a new map

Hi Night Watcher,
Is there anyway to tell exactly what has been corrupted? Will migrating to a new map help if one of my mesh is corrupted? Everything looks fine except for the viewport issue

In case it is corrupted, open you level, select all, copy, create a new map, paste, save. it may or may not work.
Is your map really large? What did you use to model you assets?

I tried your copy and pasting method without any luck. My map is rather large and I was unable to copy every item into a new map. Would deleting certain assets out of the map help determine what is corrupted? I mean deleting one asset at a time to see if the blinking issue stops? I used maya for modeling all assets with the exception of a few that were off turbosquid

If you map is really large unreal sometime struggles, which might not be a corruption issue after all. you can use the level streaming feature, and split your level into sections.

So I just clipped the ends of the landscape and around the edges and significantly reduced the size of the map and the problem still persisted. is it possible that some sort of bounds or collision issue might be causing this?

This could be a bounds issue. If you are displacing your landscape in question via World Position Offset or Displacement within your material, you could be pushing the vertices too far and causing the landscape to flicker.

Use the Positive and Negative bounds options within the Details panel with your Landscape selected. That should resolve the issue if you set the values correctly.


I tried your suggestion without any luck. I went ahead a deleted the whole landscape and still have the problem. I also migrated all of the assets to a new map and the flickering got even worst

Could you provide me with your test project so I can take a look at this issue on my end?

If possible, please upload it to like a shareable google drive link or dropbox and provide it to me in that way.

Thank you,

Yea! Thanks for your help.

I tried to download it to test on my device, but the link is dead

Sorry, Try this one

I tried to download your project but it’s huge, I couldn’t download it sry. You can go to File>Package>ZipUp Project, it should give you a smaller size file

ok. this one should be good. My Cloud OS3 End of Service | Western Digital