Download

BitMap2Material 3 Pro

I bought this Saturday, and after following the forums and watching all the different vids, "which are for releases prior to 4.6 or 4.7. and I still can not get this to even come close to working. Now I have Get Hub, installed… which I could never figure out how to link. All I know is that when I down load the demo desktop app from the Allegorithmic site… it works fine, plus I could use it at my discretion, for other programs. But now for the very same price, I can only use it here… When and if I figure it out. Please don’t anybody take me as madd at anyone… Just disappointing, because all of my production has stopped, since this doesn’t work. I bought it to progress my workflow, being a animated hobbyist with limited time, as it is., and every detail comes from me alone. Please help me figure this out somebody. As much as I hate to even have to ask for my money back, because of the dictation on how I use it for the same amount it cost for the freedom of using it across my pallet of tools I still use for Poser and the Adobe cc suite. But if I could just get it going, my creative appetite will diminish, and the above mentioned would be meaningless… I Love all that you guys are doing at Epic, so please don’t be madd if I do so find myself having to ask for a refund, but put yourself in my shoes.

Someone please… an up to date install scenario.

I have hit a bunch of road bumps as well with substance products. I feel a bit let down that unity and other third party applications get nice tech support and seamless integrations and unreal users are left with trial and error.Lots of posts flying around trying to get unreal to recognize the correct settings. Have you tried their forums?

Yes… multiple times… Then last night something about gethub, so now Ive got it, but dont understand it. Should I have to work so hard just to get it to work. I’m gonna wait… Put all work on hold and see what happens. if I stand by epic and eat the money, then I’ll understand. That all my money and work to upgrade my aim, may of been a mistake… if so… I guess I’ll take it as a sign, and just go back to what I was doing before. Hate to, now… since I got a very tasty taste of Unreal 4, but it is what it is.

I don’t have any experience with any of the substance tools but I know that it is easier for people on the forums to offer help if we have as much information as possible. Simply saying it doesn’t work is too vague and is very hard for anyone to know where to begin giving you help. So maybe give an example of what you are trying to accomplish and how far you get before you are stuck might be helpful.

Hi,

I’m very sorry for these issues.

For the install, you don’t need to compile the engine. We do have a seamless integration similar to Unity for UE4. All you need to do is download the plugin and place the plugin folder into your current UE4 project. When you launch the editor and your project, you will then be able to import .sbsar files (Substances).

Here we have a course on using Substance in UE4

This video shows how the install works.
https://www.youtube.com/watch?v=_coeFqMNUP0&list=PLB0wXHrWAmCyvb0TsSFb3UunisJHcGcuq&index=11

Cheers,

Wes

Wes… I thank you for your response, but this is how I’ve got each project set up… I put plug-in inside my project folder, like video shows… then I click…from Library of epic frontend loader to add bm2mat to project it adds a substance folder, but not anything in regards to…“I searched harddrive for *.sbar”

I just thought of something… I’m running a AMD v6 core crossfire with two hd video cards…could this be a issue?

Hold on… Ill be back I just noticed a move I hadnt’t tried yet on last video… I watched it many times, too… if this fixes it… I got a lot of shoe to be pulling from my… you get the picture.

Nope… First of all. somewhere along the line I was clicking the add to project button from library… which it did. Thats kinda misleading. The part I noticed was I was maybe creating the substance folder in the wrong place, but when you start a new build, you don’t have a materials folder, so I created one. Followed by, going in to make a substance folder, saved. exited engine, then came back and still nothing in regards to .sbar when I search to import it.

Yo. Go Window->Plugins. Is substance showing up there? If not, you haven’t got the plugin installed correctly. Probably you have, and you’re just having trouble wrangling the import thing, which is understandable, it’s weird.
From memory, you need to import textures as Substance textures, which is annoying. When you go to import a texture, hit the dropdown where it probably says “all files” or something and select “substance jpg” “jpg as substance” or whatever. If you’ve imported the B2M content to your project you should have a… I forget the name of the thing, but some special Substance-related item type you can feed that texture into as the Main Input and away you go. I am hungover as heck, this might not be helpful

Actually Joe… You are close to money there… I can put the plugin folder in as video shows, within my project folder. But has never ever showed up inside of bmp2mat 3 pro when I try to browse for anything within plugin folder,but nothing ever appears. I’ve even tried all files… nothing.

…Yet, I can go back to my project folder… and there it is…“actual installed path on hard drive”.

Yet, I was thinking at work today, about the video… It was a advanced project… “meaning the folder setup within his project is different than when you first begin to build. A new build map does not have a material folder from the get go. I reside here now from all my trial and errors”. Since I don’t have a materials folder, I created one. saved all assets even re-saved map… Just in-case… Followed, by exiting the U4 engine. Re-Loaded, created the substance folder within the materials folder. did my search, and nothing still. Maybe I should load a material so it can create one… then do the steps… I don’t know if I bare to try anymore… getting very tiresome…

>>> I’ll be back… just need to take a break. peace-Out

Well, now I can rule that out of the equation. I did notice one difference this time though. Always before… The Material folder doesn’t even appear within my search… When I added a material, then the folder appeared, with substance folder inside… Yet it was empty I did all substance import entries, followed by import all… nothing registers inside the folder. Of course it could just be because they are empty, as to why I couldn’t see them before???

Hi Goopster_1968,

Folders in the content browser will only be visible if the folder contains assets that can be used in the engine. If it is empty or contains assets that are not properly imported/not able to be used in the engine, the folder will not be visible.

Thanks Adam, So… are you saying to go ahead and place some of my images in that folder, prior to actually using, so it will appear?

}}} ‘I will try that and be back’

Still nothing…

I got one more idea to try, after I take my wife to the store… If that don’t work I guess I’ll take it as my sign to go back to where my aim was focused before making my move to U4. I really hope it works, but it is what it is. So if anybody has some good input now would be the time, because once I uninstall everything… I won’t be checking back.

Well, it still does not work. I appreciate everyone who tried to help. It’s Friday and the weekend is my biggest workflow, since I have a day job. I have to focus on something that’s going to work for me. I’ve been messing with computers for about 30 years now…and I’ve never felt so stupid in all my life. I hope everyone the best, as I bow out. I guess it just wasn’t meant to be. Peace Out and I hope to see and play some great things from this. Time to uninstall… clean up pc… and refocus. Please use my purchase of this product to better the next creative dreamer.

Hey Goopster_1968,

I’m sorry you’re having these issues. If you wish you can email me at josh.coyne@allegorithmic.com and we can work together on the issue. I work on the UE4 Substance Plugin.

Regards,
Josh

Thanks to Josh… I’m up and running like Forrest Gump. I have spoke to him about video number 10… don’t follow this video for newer version of U4. Although this video was beautifully put together and was the video that sold me on the product. They are suppose to update this, soon. Cheers… I’m back… Thanks again Josh, you made my day.

No Problem! Until we update the video (or provide a new one for the marketplace), just note that if you get Bitmap2Material 3 from the UE4 Marketplace that importing it into your project will automatically insert the .uasset into your project in a Bitmap2Material 3 Folder. No need to try and “Import” from the UE4 Content Browser.

Good to Know… thanks again.

Hi,

We will have a specific video for using B2M3 from the UE4 marketplace this week. I am very sorry for the confusion.

Cheers,

Wes