Bink video loop with a black frame at the end?

Ive seen this since some time and decided to take a close look today.I have a 5 seconds looping bink video in udk.I have set the bink texture to auto play,looping and even Reset on last frame.The video loads and when its over and prepares to loop, there is a black frame jumping on for a sec and after that the video loops again and at the end it ends with a black frame again.Is this a bink related bug or something?
I know the video is fine as it loops perfect in the video editors.Just in case, i even deleted the last few frames of the video and imported again and when the video ends and prepares to loop we have a 1 sec black frame and it starts again.Bug??

By the way, don’t attempt at importing bink videos that are 2k as it eats up like 20 fps (doesn’t matter the size>mine was just 5mb)!! 1080p should be it(unless is for a menu blank level or something similar)

Will type this before I forget(possible solution)
Looks like the black frame is because the video was in h.264 which was than binked and in udk, at the end of the loop of the video, before it restarts it gives you a black frame.

Solution(for now)
1.Export the video from your video editor in quick time format(yeah, its old and not supported anymore, but also is udk so the timing matches)
2.In BINK use compress to a % of the original and type a value
3.Leave Compress Audio on(even if you dont have audio in the video
4.In Input Video Settings do a rescale of the video(width and height> the two ones that are under the Scaling Type window)(in my case from 2k to 1080p but not sure if that step makes complete sense)Im saying that because i did a rescale of the video in my video editor first and than binked it and it was still giving me black frame at the end…

These 4 steps for now remove the black frame at the end of the loop of the video.Will update if I find anything new.Will probably have to try a older h.264 codec to see if that helps also.

If im not mistaking,BINK does require quicktime codecs to work right? I think i saw a message like that pop up when i installed it on the new pc that didn’t had quicktime on it.