Download

Binary to Source.

Hello, I have a project that I have been working on for a while now, It has been through many Engine updates and always pulled through, I think I might of broke it now though…

Basically, I’m trying to get dedicated servers to work on my Project using the 12.5 Engine but for that, you need the Source engine.
As I originally made the project using Binary converting it over to Source just didn’t go as smoothly as i’d anticipated and now when I try to compile the project via VS I get these errors:

And when I try to compile the Project within the Engine, The compile button does nothing, no success or failure message, no indication that it is doing anything.

Things I have tried:
Refreshing Visual Studio Files (Multiple times)
Reinstall Visual Studio 2015 (Multiple times)
Convert an older backup of the project (Tried with multiple backups)
Delete Intermediate, Binary folders (Multiple times)
Rebuild,Clean,Build the project (Multiple times)
Reinstall the UE4 Source engine with different versions (Multiple times)

Has anybody got any other approach that I can take? Thanks!

AnswerHub Post:https://answers.unrealengine.com/questions/464125/binary-to-source.html

Can anybody shed any light on this for me?

This is an error that I get when trying to compile a fresh project with a fresh install of VS2015 and UE4.12.5,
The engine builds fine but when you try to build the project, this is what I receive.

Did you build the engine after you download from Github?
You have to build all its binaries before trying to build projects with it; you have to build the engine on both Development and Development Editor modes (without any game project loaded). Than make sure that the Shader Compiler app is also built.

I tried your suggestion, Built the engine in Development and Development Editor, ran the editor via debug and tried to build the project in Developer Editor and received this error:
fba2833d6550d59e8c39872740c0fb23eeb25bec.png

I hate bumping things but I’m still stuck on this, I’ve put a lot of my time into this project and I would be devastated to lose it, so for the probable last time;
does anybody have any information that may point me to something I haven’t already tried?

Thanks all the same!

You have to provide more info, did have downloaded the dependencies, installed the VC++ with Visual Studio 2015 and you are running this as Admin ?

This works now but thank you for taking the time to comment :slight_smile: