Download

Big problem with clients´animations! Need help!

Hi all!
I have a problem. A problem from the sort of problems you don´t want to mess with. I set up a very very simple animation system (1D Blendspace for idle/walking/running and jumping and the animationBP. There are only 6 animations, 3 for jumping and 3 for idle/walking/running). I started the level in multiplayer and the client jiggled very fast to the left and right while moving left/right or backward. It makes no difference whether i play on a dedicated server or not (i use the ingame options, there is no real server and not even cooked data). Only the Clients have this problem!

I have this problem the second time, in the second project with the second skeleton. Thie first time i didn´t change anything related to animation, only the ThirdPersonCharacterBP. Here´s a video of the problem https://youtu.be/sNON0qLPQ2g

As i said, this is a very basic animation setup and i didn´t complete it. The rough animation-translation on the Server is my fault.

Did you solve it? Best practice is if you solved your own problem is to follow up as to the solution.

But.

Looks like your character is fighting between two different animation types by mixing in place with root motion and is not being replicated to the client. With in place the movement component hands all of the translation replication for you where with root motion you will need to replicate the event activator IE what key was pressed that causes the player on the client to move forward in the same manner you would have to send a replication to make a chest open.

The other possible issue is if you did not tell the animation BP to use root motion, or ignore it if applied, then the movement component is still activated and as demonstrated in the video is the result of the RM attempting to play the cycle but is forced by the MC to snap back to the capsule root.

Thanks for your reply! You helped me “indirectly”. While i was searching for the root motion setting (i can´t remember where i saw them) i found the Option “Orient rotation to movement”, i unchecked it and it worked! I have absoulutely no idea why it was checked, because it was a clean project and the standard setting is, that it´s unchecked.

Thanks for your help