Big ball shows up in random places in my scene on play

Hi there,

I just set up a particle system for dust and I am getting this random big ball showing up in my level when I play it.

I have sequencer set up as well and it only happens when I running through the sequence. I have rebuilt the level and everything.

https://i.gyazo.com/69b2906159543f1629cd94f2cf8a9505.png
https://i.gyazo.com/6d15522ad155090ef7ab4a22296b6467.png

Update, I just realize it shows up randomly where my lights are… strange. Any ideas on what it could be?

Appreciate any help

Happy Holidays
Dema

2 Likes

Hi Dema,

That’s most likely the DefaultPawn actor. You probably can move it around the scene with W, A, S, and D keys. It’s set automatically in the GameMode and I don’t think you can remove it or even set it to None. However, you can very easily change it to any other Pawn class and potentially hide it from the game. Below is the step by step guide on how to accomplish this:

First, create a blueprint class based on Pawn (Right click in Content Browser > Blueprint Class > Pawn). Name it whatever you like (Let’s call it BP_MyPawn).

Next, open it and on the right side, in the Details panel, under the Rendering category, check “Actor Hidden In Game”. Compile and close it.

Finally, open your Project Settings (Click on “Settings” above the Viewport > Project Settings). Navigate to “Maps & Modes” settings. Expand the default GameMode options by clicking on that arrow below it and change the “Default Pawn Class” to the newly created Pawn blueprint “BP_MyPawn” (You might have to set it in the World Settings as well if it doesn’t update automatically. You can access it from Settings > World Settings ). That’s it! close the Project Settings window, Click Play and it should not be visible anymore.

Note that once you click Play, you will not be able to navigate through your scene anymore with mouse and WASD keys as before. Those input behaviors were set by default in the DefaultPawn. If you don’t want to implement your very own behaviors, you can very easily bring those previous input functionalities back. Open BP_MyPawn, (Click on Open Full Blueprint Editor if it opens in Class Defaults mode). On the top panel that appears, click on Class Settings and on the right side in the Details panel change the Parent Class to DefaultPawn, making sure that “Actor Hidden In Game” remains checked.

Hope it helps.

Happy Holidays,

Vizgin

1 Like

You’re welcome. Please consider marking the question as SOLVED to help the community in both referring to this solution and also better filter the unanswered questions.

Thank you so very very much!!

There you go, sorry, it is the first question I have asked of the community. Thank you again, you were a huge help!

Thanks to your help, I was able to finish my first ever level.

Unreal Engine Project - YouTube would love your thoughts if you feel like giving them

Dema

This looks great Dema! However, unfortunately, I’m not an artist so I can’t really give you any useful artistic feedback, nevertheless, here are a few small things that you might want to consider tweaking in your rendering:

  • Your camera seems to be lagging a little bit and doesn’t have that smooth movement. It’s most noticeable at 0:25 - 0:30. You might want to increase the framerate or find a workaround for it.

  • Your brick cubes at 0:18 don’t seem to be casting any shadows on the floor.

Other than these two, I think it looks great. Keep up the good work mate :slight_smile:

Why Is It So Complicated To Do Something So Basic With UE, Like I Want Multiple Characters That I Spawn As Pawn The Posses And Use In My game, BUt NO, YOU HAVE TO HAVE A GOD DAM PROBLEM THAT MAKES NO GOD DAM SENSE

That’s the mesh for the default pawn. You can create a new spectator pawn and set it as player pawn in World Settings to get rid of that mesh.

Create Spectator Pawn BP And Use It To Replace The Retarded “Default” Pawn, FK, In Project Settings, Maps And Modes

In Project Settings Set Default Pawn To NONE, Then It Removes It, When You Spawn Your Pawns, And Then Posses, It Will Simply Work, Without Problems, BRU