Bifrost breaking when loading project

Loaded in a Bifrost mesh animation using Alembic and have a nice looking liquid animation in the scene. However, let’s say you close ue4 and then reopen the file to continue working, the Bifrost mesh animation has no material slot and thus disappears from the level. This remains true if you package it. Not very useful if it can’t be seen.

I am really excited about bringing Bifrost into unreal and hope this feature gets fleshed out.

(also, I can’t tag Bifrost to this post)

Hey Bandit455,

Can you send me your Maya and Alembic files? I’d like to see what you’re working with. You can PM me a download link on the forums.

-Matt W.

I apparently don’t have authorization to use the PM system.

119772-6ec2defe5029cfbfd26cd7e3db0fdbf7.png

Hey Bandit455,

I’m reaching out to our Community Team to see what the issue is here. They are not in the office until after New Years. Apologies for that weird permissions issue.

-Matt W.

EDIT: Remembered that new accounts can’t PM until they’ve gone through first post moderation. I would need one of our admins to override that or you could make a post and our mods can approve it.

Your account has been upgraded out of first post moderation. You should be able to send PM’s now.

Hi Bandit455,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

-Matt W.

I’ve just sent a pm to you with the files. Sorry for missing your earlier reply.

Hey Bandit455,

I did some experimenting and was unable to reproduce the issue. The Bifrost animation works just fine in the level. I import, add it to the level, save the level and asset, then re-open the project. Can you give me a breakdown of exactly what you’re doing when you import?

Are you sure you aren’t viewing the backside of the mesh without a two sided material?

-Matt W.

Alright. So… now I can’t reproduce the problem lol. It seems to be working now and I don’t know why but I guess I can be okay with that. Perhaps it was an update that fixed it? Either way, it’s working in 4.14.3 both after saving and reopening and even in the packaged game file.

Thanks for all of your help!

Cheers,
Bandit

No problem, glad it’s working. The bifrost setup and export process is a bit tricky to start with, so maybe some checkbox was messing up the asset. Let me know if this crops up again. :slight_smile: