BFX Bad Size Player Start


I imported the model of a ship on my UE4 project as individual meshes. When the model is imported (after a long period of time) and set into the scene i try to place the Player Start actor inside the ship (let’s say inside a cabin). The Player Start turn to Bad Size and this label desappears only after i drag the Player Start away from the ship. Even then i cannot approach the model and walk inside the ship. When i used unity engine and imported the model the ship was passable by a player character so i think that the model is ok.
Is this a problem that come from the model type (BFX)? is it related with the warning when i import the model that the meshes are small (i scale them)? any ideas?
The model is huge and composed by 1180 meshes.

thanx in advance :slight_smile:

Which kind of collision do you use for your mesh? :slight_smile:

I had that exact setback. It’s all about the collisions.

I edited some of the meshes and the colliders occupy a large amount of empty space around and inside them. As an example the ship’s restaurant is a separate mesh and is almost completely surrounded by an invisible collider. How can i reduce the colliders to match the walls or the other objects???

Take a look at this video: :slight_smile:

I watched your (very useful) videos yesterday.I couldn’t understand how to reduce the collider… Do you think that I have to use the third way? I modified ther model on 3D Studio and is composed by many separated pieces (1180) so i think is not recommented to import them one by one on Blender and apply the first two ways.

It works the same in 3ds -> so you dont need blender. :slight_smile: When you create the collision in a 3d program you will have to make sure that you disable “one convex hull per…” in the import settings. Otherwise you can also use the 3rd way -> not so good for the performance, but you wont feel a real difference

Solved! I unchecked the “import collision” and "one convex hull per’ selections on import settings and i applied an two sided geometry, 26DOP Simplified collision and selected the “Use Complex Collision as Simple” option on edit… And WORKED!!! the Player Start is not Bad Sized and navigation inside the ship is waesome! Thank you very much and good luck with your project!