Best reimport option, because reimporting is bugged

Hello, can you suggest the best way to reimport a mesh? In archiviz there are plenty of modifications and updates, but all reimporting options are just bugged. I tried with datasmith with c4d but sometimes it doesn’t get all materials and they are imported grey, sometimes instead works, but seems not to be a reliable method. Fbx reimport option has the same issues. It’s bugged, sometimes it reimport correctly, sometimes overlap deleted objects, or make a mess with materials. At a certain point I just delete everything because I spend less time reimporting from 0 and reapply all materials, but doesn’t seem to be a decent way to work. Twinmotion that uses unreal engine works ok instead. So I wonder if there is some trick to solve this waste of time.

Can you confirm that your context is:

  1. datasmith import of C4D
  2. manual modification of position and material etc
  3. modif of C4D
  4. reimport that does not preserve the manual change you did in 2)

We need to understand what fails to be able to fix the reimport process as you should not lose information.

As a workaround did you look at the Visual Dataprep functionnality. You create a “recipe” to process the scene and assets that comes in UE.

1 Like

Thank you for the answer.
About Visual Dataprep functionality, no, if you please can send a link I will check it out.
To be more precise, reimport function works with datasmith. The problem is the the first importing. I use the same procedure, saving with assets to obtain all the texture, saving for cineware, but sometimes all the materials are gray.

So you mean that on fresh import from cineware sometimes you get assets and their materials properly set and sometimes you get a grey material?

In that case it sounds more an issue with the C4D importer.

For visual dataprep you can have a look here
But I recommend it as you can define some rules to apply materials on import. And that is easy to reapply on every import. But that will not save you if the original import fail to create the proper material.

Here an example of what is the import result. A couple of materials are imported right, all the others are not.
It’s not a texture problem because no one of my materials had textures applied.
I’m using the same cinema 4d version and same way to export file, saving as cineware. So the workflow is so simple that I can’t see how can be a c4d issue. I also tried to use c4d 25 instead c4d 23, but the results are identical.

Could you share the model in a private message with me?

It seems your editor is performing poorly due to low video memory.
Is the editor still in the process of building shaders/materials? That would explain why some materials are still grey.