Download

Behavior Tree MoveTo

Hello, everyone!

I’m trying to learn as much as I can about the AI in ue 4, but unfortunately, I ran into a bit of a problem.

I have a behavior tree, which was working just fine on 4.1, but after launching it on 4.2.1, the navigation system seems broken. The characters are not moving an inch. I’ve heard that the blueprint MoveTo is not functioning correctly in 4.2, but this should work, right? Could someone please help me how to solve this problem?

unreal.png

Thanks in advance :slight_smile:

Acceptable radius 10.000???
Pretty sure thats your problem, 10.000 unreal units are like 100 meters, and its quite a bit of space. Probably your AI is closer than those 100 metres and the goal just does nothing. Try putting a lesser value in AcceptableRadius, like 100

Okay, that was pretty dumb of me…

But unfortunately not the source of the problem. :frowning: I have other AI-s with acceptance radius of 50, and yet they still don’t move.

I’m thinking of creating a new project, and just copy-paste all the important stuff. Maybe it will solve it.

– edit –

I started a new project, copy-pasted everything and now it works. :slight_smile: Something must have gone wrong at conversion.

That’s odd… Let us know if anything else goes wrong! Preferably on the answerhub :smiley:

Have you updated to the Hotfix?

BT’s were broken that used blackboards or called functions on other Actors, at least I think that was the bug. My complex trees were broken in 4.2.1 but fixed with the hotfix.

I found that in 4.2 any move to actor or move to location, whether it was a simple or a aicontroller node. It would not move at all, or get called as successful. Only Move to actor from the ai controller worked. So I reworked my AI completely without behavior tree just because the god **** moving didn’t work at all… Haven’t tested yet in 4.2.1