Download

Beginner Problems

I just started using Unreal Engine 4 the other day. I had been using Unity previously. So far I really like what Unreal has to offer.

I have had some issues though. I got a sample game thrown together, based off these tutorials: http://www.youtube.com/playlist?list=PLZlv_N0_O1gZS5HylO_368myr-Kg2ZLwb

When I run the game on my PC, it works just fine. When I build it for Android, it spits out three files, a .apk, a .bat, and a .obb. According to the documentation, I should plug my tablet into the PC and run the BAT file to install the game. When I do this: ab2a402e7cf76d87cb984edd2279517916accb95.png

Back when I was using Unity, I could build for Android and it spit out a single .APK file, which I could transfer to my tablet and install to test. I tried this with the Unreal .APK, but the app crashes as soon as I try to open it.

Thanks for the help!

First of, make sure USB debugging is enabled.

And don’t forget that every Android app must be signed to be installed.
http://java.dzone.com/articles/android-solution-install-parse-1 generate keystore via keytool how it’s described here and generate Android manifest files, to do that go to project settings -> Android.
Then, in your staging directory, “Android” directory will appear, you can navigate there yourself or click “Open Manifest Folder” in Android project settings. Edit SigningConfig.xml and now your .apk will be signed during packaging.

You can use “Launch” button within editor itself, application will be installed on your device if it’s connected and USB debugging is enabled, but launching this way might produce some errors eventually, as it did for me.

Hope this helps at least a bit.

Alrighty, I tried all the advice above and I got some results, but the problem is still not completely resolved.

I checked that extra box and now it produces a .BAT and a .APK. But now it is over 400MB!?!?!?!

I figured out why Unreal couldn’t find my device, I was using one of those charging-only cables! Noob mistake!!! I am using my HP Touchpad running KitKat 4.4.4. That should work right? Once I hooked it up with a data cable, Unreal immediately recognized it and I was able to use the Launch on Device option. It built it, deployed it, and the app crashed as soon as I tried to open it :confused: I never got any error messages in the Output Log.

Any more ideas what could be happening?

Are you tapping the project once you see it show up in the list or are you letting it launch on its own after deployment? One thing I’ve run into a bit on android (especially when connected to adb via wifi) is that ill try and launch the game before it’s full deployed, and it’ll always crash immediately. **Always **wait until the app launches on it’s own before trying to open it.

To see if it’s a device or a project issue, I’d start troubleshooting by trying to get completely blank game running on device. maybe show FPS on as well, but start with just a cube, stationary light, and nothing else. A blank project will deploy and run fastest.

Ok, I got the Launch working to test it out! Turns out I was using a cable just for charging the device, no data -.-

I am quickly making progress, but I still got a few issues. My main vehicle is rendered completely black with no depth to it when I run it on any mobile. It renders fine on my PC. I saw something on another post about this, but they guy was still waiting for answers.

Also, I am using the default HUD controls for movement. I got the left one controlling direction and the right one controlling my camera. Is there a way to have the rotation of the camera reset when the user stops giving inputs on the right pad? I want to camera to point back at the vehicle.

Is there a way for me to make the direction of travel controlled by the position of the input around the pad and the speed by how far from the pad the input is? I hope this makes sense :slight_smile:

Thanks for the help!

Anyone???

In Android Developer Settings their is options to change increase or decrease your user experience which is done by changing rendering speed of UI for debugging.
you should look into documentation of debugging using developer settings.