Begin Play suddenly stopped working in 80% of cases

Howdy, everyone! :hugs:

I’ve been trying to figure out this mystery for hours now and couldn’t quite get there.

So what happened is…
Everything was working fine for months and today, out of a sudden, Begin Play event stopped being reliable and started to fail in about 8/10 cases - meaning, if I try to enter the level ten times in a row, it will most likely fire about 2-3 times, that’s it.

The most interesting thing about this is, that it actually fires time by time and it seems to do so pretty randomly without any pattern to be seen.

This issue seems to be affecting only a Character Class that is being a parent for all the other Character classes that inherit from it - Begin Play works just fine within these children classes for some cryptic reason.

I have tried debugging via prints (right at the start of the Begin Play).
There are also no errors within Output Log.
Tried restarting, recreating variables, different levels, reassigned all classes within GameMode and more thingies that I probably already forgot.

No biggie if we don’t figure it out, I can always just revert to the latest stable version.
Nonetheless, if anyone has any idea what might be causing this, I’m excited to hear it!

I wish a nice day to everyone! :innocent:

After further investigation, it turned out that the class got most likely corrupted in some way after the UE crash.

If anyone encounters a similar issue, I recommend just deleting and recreating the class.
That’s what I did and Begin Play event now works just fine.

1 Like