Download

Begin Play Event won't fire

I have no idea why or how this is happening, I’ve never had an issue like this before. It doesn’t fire for any actors in the level either that have Begin Play event. I’m even trying this on a new empty level. I’ll add a picture to show. I tried with a single print screen with no effect, then made a .02 delay loop just in case I missed it.
Capture.PNG

Hi Mahelyk,

I just attempted your exact setup on my end and it seems to be working as intended. Did you place a copy of this blueprint into your level? For instance. If you create a new blueprint actor and give it that functionality, compile the blueprint, place a copy of it in your level from the content browser, then press Play in Editor, does the blueprint functionality work?

No, I tried that and it doesn’t work. I can do it on other projects just fine, but the begin play functionality doesn’t seem to work on my current project.

your actors inherit from a c++ class?

Well I’m using blueprints. But the level blueprint is just the level blueprint. And when I made a testing actor to see if Begin Play fired from them, they are just made from default actor.