Download

Begginers retargeting question

Hi,

Few days ago I’ve decided to move my project from Unity to Unreal Engine 4. Most of the things I get, and I’ve successfully managed to re target few skeletons.
Currently I do not understand what to do if the skeleton you wish to re target to default humanoid one is missing one of it’s spine bones?
I have 100+ animations that I used in unity that share this problem.
Like this:
a6e28b8006f962c3cd51bb0a87704439f645a391.png

I’ve tried re targeting as a test by placing spine1 in spine1 and spine 2, it does work but the results are not very good.

check these 2 links ‘closely’ - they’ll usually fix most issues with retargeting:

https://docs.unrealengine.com/latest/INT/Engine/Animation/RetargetingDifferentSkeletons/

because sometimes it helps to set the skeleton like here (after doing the above):
https://docs.unrealengine.com/latest/INT/Engine/Animation/AnimHowTo/Retargeting/

you can also ‘show’ the skeleton & names in the viewport under the options at top, which might help
only having 2 spines might not be good sadly or may be hard to match up

personally, I would try not retargeting at all unless you need the default animations or the animation pack from learning tab in launcher.
you may only need to import them correctly if you already have animations, it’s what you have to do with blender unless you just like ‘pain’.

to make it short n sweet, retargeting to the humanoid isn’t necessary to use animations that you made yourself.

*note: always give details like what 3d software you are using etc. - it will help you find someone with the correct answer for your situation.

hope this helps

*edit: forgot to say, you can also just retarget to your own skeleton by setting ‘it’ as the humanoid skeleton. it will save you a lot of room as well as being able to share animations etc.

Thanks for the reply.
I did not make the animations myself, they are a part of animation pack I imported from Unity.
I will try setting the imported skeleton as the humanoid skeleton and see if that changes anything.
Thanks!