Download

Been unable to create any mods with the Devkit

Hello I have tried for some days following tutorials and creating a mod. Every attempt have worked in the editor but not in game after cooking.
Last bunch of tries has been to just remove all engrams from the engram list in gamedata.

  • I have used the genericmod files and renamed them properly, keeping the required parts. Even tried with the default gamedatas copying and renaming those.
  • Tried with forcemapload TheIsland and empty, have set the primalgamedata to the correct one in the level.
  • Tried with using my renamed gamemode aswell as the default game mode.
  • Wrote the mod name and description in the primalgamedata.
  • Tried running the launcher as admin and not.
  • Checked the output directory that they contain the required files.
  • Tried to cook and upload to steam aswell as to my mods folder.
  • Had friends testing the mods and they dont work.

Cooking generate 1255 warnings and no errors.
I am on windows 10.

SOLVED: THere was a two part problem! First of the loot mod I attempted to make before was simply not working. You cannot swap out dropped inventories and remap the npc to your modified one.
Second was local testing, you need to copy the content inside “yourmod” folder to the “123456789” folder for it to work… Amazing all them tutorial and it never mentioned that part.

not quite sure myself, but i dont think you’d want to mess with “game mode” unless you really really know what you’re doing.

and have you tried running the mod on PIE as dedicated server? honestly no clue what you were trying to do, but if you want to test the mod out to see if the changes you made only work on server-side or client as well or not, just try running PIE with as dedicated server and your character in PIE would be labeled as client and then you’d be able to test what went wrong, further.

Ive been testing my mod in the devkit both as dedicated standalone, pie etc. It works there every time :S When I cook the mod, and start a game with it, it does not work anymore.
Yeah I have tried without having a specific game mode file aswell no luck :confused:

just cuase it runs it pie doesnt meant it will run ingame i have issue where it runs fine in the devkit just not ingame 100% of the time its rep issue did u make a basic mod or did u edit the graph

I literally did only the following:

Copied the 3 files from genericmod, renamed them GenericMod_TestModB wich is the map.
PrimalGameData_BP_GenericMod_TestModB
TestGameMode_GenericMod_TestModB

Changed the maps gamedata override to mine, filled in the details in primal game data and set the gamemode.

Went into my primalgamedata file and pressed the trashcan next to the engrams, tested it in the editor. It works no engrams, cooking it to my mods folder and testing it in game and it doesnt work.

EDIT: Its really bothering me how I keep going through tutorials to find the same thing im doing, either im blind or something else is wrong here

Do you not have the mod selected when you play? It was confusing for me when I started modding, because I thought it showed the mod was selected, but it turns out it wasn’t.

When you say cooking to my mods folder, are you filling in the shootergame/content/mods in the cook dialog?

the cook process produces a mod 123456789 folder and real content in a separate ‘modname’ folder together with a 123456789.mod file. A different layout than a normally installed mod.

I have not got direct to content folder cooking to work reliably. While developing locally, I cook to another folder then copy the content of the cooked ‘modname’ folder over my previously installed mod content the numbered folder in the game mod folder. I use ‘beyond compare’ to identify the changed files. But this does rely on having done a steam upload and install at least once!

Hope this helps!