Download

Battery Collector Tutorial Videos - Error saving ThirdPersonCharacter Blueprint with Workaround

I’ve been working through the Battery Collector Tutorial videos on engine version 4.20.3, and have come across an error with saving the ThirdPersonCharacter asset. I don’t know why or how, but whenever I try to “Save All” in the editor I get this error: Error saving’…/…/…/…/…/UnrealProjects/BatteryCollector/BatteryCollector/Content/ThirdPersonCPP/Blueprints/ThirdPersonCharacter.uasset’

I have checked for solutions including checking to see that only one instance of the editor is running (my computer freezes if more than one instance is running so that’s not my problem). The file permissions for the character asset have not been changed “magically” like some people have reported (I’m using windows7 and I checked to make sure the file was able to be read, written, and modified by my user name). And the file or asset is not in use by any other program (I restarted my computer, once booted and ready I opened the editor with the Battery Collector project only, not Visual Studio.) I also tried deleting the Third Person Character Blueprint completely from the project, however when I restarted the project another default Third Person Character Blueprint was created automatically, and still had the same error with saving.

After none of the above potential solutions worked, I created another Third Person Template project, with C++ code, and checked to see if I could modify and save the Third Person Character Blueprint. I was able to modify and “Save All” with no errors on any asset in the newly created template project. This leads me to believe there is a problem with just my Battery Collector project, and not a system or editor/engine problem.

Due to my Battery Collector project still having errors with the Third Person Character Blueprint, I decided to make another character Blueprint and set it as the default for the tutorial project game mode, replacing the Third Person Character Blueprint. To accomplish this I duplicated the existing Third Person Character Blueprint, renamed the duplicate, and modified the duplicated character Blueprint per the tutorial videos. Once the duplicated Blueprint was ready, I modified the game mode source file to use the duplicated character Blueprint as the default PlayerPawnBPClass.

Changing the default player pawn Blueprint to my duplicated Blueprint allowed the modified character to “Play” in the level, showing the material and power changes as per the tutorial videos. I still have the error saving the default Third Person Character Blueprint, however since I am not using it in anyway, I believe I can safely ignore the error.

I know this is just a hack/workaround of the issue, however it will let me complete the tutorial videos. I’d like to come back and find the root cause and a real solution to this error after I complete this tutorial and a few more projects for a demo website.

I wanted to write up this workaround for anyone else who has a similar problem and needs a way to continue their project.