Download

baking incorrect .....bug?

So all morning I have been working on a scene and baking lighting with no issues. I didn’t change any lighting or move any objects. I updated a few texture maps in the shaders and did a rebake and now I get huge black walls and looks like the light is not being baked correctly.

Is this a bug or something that I am doing wrong.

Thanks
Alex

Lightmaps all good? I think I’ve had this before and I messed my lightmaps up.

Sometimes, you just have to flush your Lightmass cache to fix inexplicable issues.

How do you flush your LM cache?

When you build lighting, the Swarm Agent icon will appear in your Windows taskbar; click it to open the Swarm Agent. Inside, click on “Cache” in the menu. More details are provided here:

Thanks I will try that and see.

That seems to fix the issue. Thank you. Although I have to do it before every time I bake.

That’s certainly not normal. You may want to try the “Validate” cache option. Or as a more drastic resort, possibly even locating your SwarmCache in Windows and deleting the contents of the sub-folders (the link I provided explains how to locate it).

Hi,

I have the same problem on my computer (i7-7800X - 32GO ram) with a scene. Same effect (black faces on some meshes) appear each time I build lighting. But on another computer, the problem doesn’t seem to appear, with the same scene and lightbuilding parameters. I tried to flush my cache, validate option and even deleting all caceh folder, nothing changed.

Could I reinstall only swarm agent ?