Download

Baked light problem

Hello! I am an architect and I am a beginner in the use of the Unreal Engine. I’m trying to create archviz VR experiences, mainly by following tutorials. Right now I’m having trouble trying to bake lighting. I have been setting the lightmap resolution of each static mesh so that they have an adequate textel density, but at the time of baking lights, I get the result that is seen in the image. Unfortunately I don’t know how to create UV maps myself (I use sketchup to model and then twinmotion to apply materials before importing the project into UE4). I would need, if possible, someone to help me solve this step by step, since I saw some solutions in other threads of this forum but I was not able to follow the instructions. Thanks a lot

Best to watch some videos on YouTube like this one here

Thank you for the answer. What that video shows is similar to what I had already seen in other tutorials. As you can see in the images, I already increased the resolution of the lightmaps, but the error still remains. Keep in mind that in other attempts to make this project, the lighting had worked well for me, but in this case I am starting the project from the beginning, to avoid having unused assets and that everything is more orderly in general. That is why I do not understand what the problem that generates these lighting problems may be.

I think you get better control of the light maps when you use unwrap them in the modeling program [maya/3dsmax/blender]. Ue does a ok job flattening the models if you don’t but sometimes they don’t work well.

There are actually 2 sections for lightmap in the mesh browser. This can be confusing when you’re new to Unreal.

  1. In the LOD/Build Settings: Here is where you create the lightmap
  2. In the General Settings: Here is where you actually set the resolution and the channel for the lightmap.
    See attached image. Make sure you set the light map id and resolution in the general settings to the same that are used to create the lightmap.
    You created a lightmap for a resolution of 32 but you use the lightmap size of 1024 in the general settings. You need to create a lightmap with the resolution of 1024. Don’t forget to hit the Apply button. This might help. If it doesn’t then you need to create lightmaps in a modelling app like Blender.

thank you! that solved part of the problem. It was also happening that twinmotion was creating some weird lightmaps; when importing directly from sketchup the lightmaps were much better. Thank you very much for the reply!