Bad performance with AMD R9 290 gfx card

Recently upgraded from a HD7950 to a R9 290. My old HD7950 had no issues running the in-editor window at a solid 60 fps on high scalability settings. However my R9 290 is all over the place, often dipping to the low 20s (no matter the scalability settings I use). Even when I try to test my game as standalone, the performance is terrible. When I look at the monitored values of my graphics card, it seems it’s neither being fully and consistently utilized, and it’s not running at its full clockspeed (it jumps around constantly).

Now this might be an issue caused with the latest Catalyst drivers (14.9), but I don’t know for sure. Does anyone else have this problem with AMD’s latest gen of graphics cards? Is there something I can try to fix it on my end?

Edit: want to note that when I package the project as a Win64 executable and close the editor, the packaged project does run fine (except with some judder issues when looking around, which is a common problem with Rift titles atm). Seems it’s a problem with the editor probably?

I had the exact same problem when i first installed my new sapphire tri-x oc 290.I was going crazy!I could not believe that my system was going as low as 12FPS.So i changed drivers,uninstaled the card from my motherboard,i started running 3dmark benchmarks to see if my card is broken.But when i saw more performance points than an i7 4770 with a Titan then i knew something else was going on.

It appears that the bigger your blueprint becomes the more the FPS drop!!
The performance drop you are seeing(if of course your card is not damaged) has to do with the fact that visualizing blueprints is more cpu and gpu intensive than Dead rising 3. :slight_smile:

What i did was select a branch of actions (for example my walking logic) and right clicked.Then you can select “collapse nodes”.For every Node i created i gained about 10fps!

I hope that this is your problem as well and you do not have a bogus card.If the above does not work and you card is working fine then you might have a CPU bottleneck in case your processor is weak ad cannot handle an r290.

Let me know how things went.

It does seem that opening a Blueprint causes a drop in performance. However if I then close the project, reopen it (without opening a Blueprint), the performance is still bad. I’ve got a 4770K btw, so that can’t be the issue.

You are right your CPU is beast.The only other thing that i can think of is that you do not have a good PSU and you can’t feed the system with enough stable power.For your system you need 800+w.Download the free version of 3Dmark run a bench mark and see the results.If the are on par with your configuration then maybe it is a driver issue but i am using the same one as you and without any blueprints open i see 120Fps on a 6000x1080 resolution.
How much RAM do you have?

I’ve got a 800 watt PSU (and that’s actually a bit overkill, initially intended for a Crossfire setup), and 16GB RAM. The thing is, my R9 290 performances just fine in games and whatnot. Battlefield 4 runs 90 fps at ultra settings while the Tri-X coolers keeps the temp well below 80C. I’m pretty sure the performance problems are either within the drivers or UE4 itself, not with the hardware.

I will not deny that i have the feeling that unreal has some weird performance issues since i have experienced them myself but since we have the same Gpu and i have a lot more performance than you with probably three times your screen resolution then i have to speculate that it is a driver issue since i have an all Amd build and your cpu is intel.Try installing the latest stable catalyst and see how it goes.Actually the best stable release i think was 13.2