Download

Bad lightmaps on meshes converted from BSP to static meshes

Hi, after conversion from BSP to Static mesh I cannot bake lightmaps for objects converted in such a way.
When inspecting mesh properties, the ‘Generate lightmaps UVs’ is checked, ‘Destination lightmap index’ is set to 1
and if I inspect UV mappings the ‘UV channel 1’ contains valid mapping, but after baking the object is totally black.

The trick to make it tick is to export converted Static mesh to FBX and then (without any changes) reimport it again … it is know problem, and is there any other
workaround for it (exporting 100 of object into fbxes and reimporting sounds like real pain !)

Hi MXADD,

Make sure that you’ve set the Lightmap Coordinate Index to be 1 as well. Often when creating a BSP and converting it to a Static Mesh this will still be set to 0 for the texture UV.

You can set this in the Static Mesh Editor, under Static Mesh Settings tab on the right.

You can see how to do this in the Wiki Lighting Troubleshooting and Tips Guide here: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums

Hope this helps.

Tim

Nope, I’v set Lightmal coordinate index to 1 as you suggested (it was indeed 0), rebaked lights and still the object is black … see attached screenshots (the simplest repro case is to put BSP box on empty scene, add some pointlight, convert BSP to static mesh and bake light - object is black (its ‘static’).



086655559c93dae8e0760d15c15d2fdfe80e8ca2.jpeg

You’ll need to set the Lightmap Coordinate Index under the tab for Static Mesh Settings in the Static Mesh Editor.

In your last image you’ve set the Build Settings. This is just for generating the lightmap UV and has no bearing on setting the Lightmap to the use the correct index. In the Wiki guide I linked above you can see the panel that needs this value adjusted or you can type in “Lightmap Coordinate” into the search bar at the top to set it correctly. You’ll probably also want to adjust the lightmap resolution. By default when BSP is converted to Static Mesh it will be set to 4. Try starting with a low value like 64 and adjusting accordingly.

Anything in the Build Settings will not change these values for the actual mesh.