Download

Backface Culling Problem!

Hi everyone, I’m new to the forums and I’m switching over from Unity to Unreal. The problem that I’m having is that I’ve modeled a base interior for a house starting from a cube primitive (i’ll post pictures below) and used backface cull to see the inside while I textured everything. However, I turned backface cull off to export as .fbx for use in Unreal and the object still appears in Unreal with backface culling. How can I change this so the house outside appears solid? I want to have a character inside the building without view of the outside world. Thanks in advance I’ve been trying to figure this out for hours.

Are you 100% sure that you have set it back to solid? -> or is the roof still just a plane? :slight_smile:

yes I modeled everything from a cube primitive just by extruding and moving verts to make sure that everything was quads and tris. Then turned on backface culling to see the inside for texturing and then turned it off again to export but I still get this result

I look at some other posts about normals and realized that my normals are flipped but when I try reversing them my textures get wonky do you think this is the problem and that I’m going to just have to re-do all the uv mapping and texturing?

I know this post is old, but I have exactly the same problem now…

Try setting the material to two sided.

Best practice though is to build object to both form and function so a roof should have 2 face sides as a real roof would have. An outside and an inside.

I think FrankieV is right, you will have to enable ‘two sided’ in the material properties of the mat that you apply to the roof/walls. I believe disabling backface culling in max or maya is just effecting the viewport inside that specific software and is no information that you can export along with your model.

If you do not model with enclosed surfaces then use double sided material for thin faces. Other thing that could happen is while you were modeling either at mesh creation time or while editing you might pull some faces to negative direction that will cause rest of mesh to flip faces… Eg if you create box in 3ds Max and one of dimensions have negative value, your whole box will have flipped normals, that is intended behavior. One way how to check that is select object > right click > quad menu select “Object properties…” > check “Backface Cull” on > click OK