Axis Input not registering in Pawn

  • I’ve started from scratch with a blank project.
  • I have my own GameInfo.
  • My GameInfo loads my own DefaultPawn-BP.
  • I have my own Controller-BP.

I have set up axis in Engine - Input.

These work absolutely fine and are registering in my Controller class.

However, they don’t register any change/input in my pawn-class.

The YAxis value is always 0.
However, the pawn DOES take the example V-input you can see there.

I’ve tried different Default-settings for the Pawn-class as well in regards of “Recieve input” and “Auto posses”, but it doesn’t change anything.

Any idea why the value of the same Axis is always 0 in the Pawn-class but not the Controller?


Do you have the axis bound in both your player controller and the pawn? If so you’ll need to uncheck consume input on one of them (I can’t recall which gets handled in the input stack off hand).

I have the “InputAxis YAxis”-node in both the controller and pawn, if that’s what you mean by bound - yes. Is that “wrong”?
Where is the “consume input”, and does that mean “I’ll hog all the input from everyone”?


In the ‘Defaults’ Tab of blueprints, just search for input and there will be a ‘Consume Input’ check box. Basically, once that class takes in an input, no other classes will be allowed to use it. Just uncheck it and see if that does the trick.

Do you guys mean “Block Input”? If so, it’s unchecked, so that’s not the reason unfortunately.
There’s no “Consume Input”.

Marc is referring to the Consume Input option in the Details panel when you have your InputAxis node selected in the Blueprint editor:

You’ll want to make sure this is un-checked in both blueprints if you’re calling it in both the Controller and the Pawn.

Aaaaah! Sorry, my bad.
Okay, found it.
Unchecked in both location, but nothing changed I’m afraid. :frowning:

I’m also having the same problem. All my keyboard inputs work 100%, but none of my mouse inputs function. I tried the Input Axis Mapping as well as the Mouse X and Mouse Y defaults in BluePrint, but I cant seem to get them to work.

Ok I found my Mouse X and Mouse Y defaults are working, the values were just very small that I didnt see their effects.