Awful performance during gameplay due to lighting

Heyo, first up here’s my PC’s most important specs.

GPU: GTX 1080 2x SLI

CPU: Intel I7 4790k 4,2ghz clock

RAM: 32GB Corsair vengeance

I also have Nvidia Surround enabled with 3 monitors.

Now, onto the issue.

So, I’ve got this rather small scene set up

It contains some foliage and mostly stationary lighting, the grass and trees are both set to static shadows and I’m also making use of the new volumetric fog.

Now in editor, lit and realtime this scene runs at 120fps from the players perspective. Knowing that 120fps is the editor limit it could probably run even better.

Here you can clearly see this


As soon as you press play, Unreal engine takes a massive performance hit

This is not exclusive to this scene or even this project, a near empty level from my friends project runs much worse than it should. Going to about 55fps on what’s essentially the standard fps project.

I’ve gone through many checks, I’ve checked CPU usage. It’s never above 40% and removing all blueprints and programming from the scene gave no advantage.

The main issue seems to be lighting.

If I turn off the lighting while playing in editor the game runs at 120fps+ turning it back on dips it back down to 49.

Now my question is, why does the performance only take a hit while playing?

I’ve packaged the game as well and it sees the same crappy performance.

This issue turned up recently so I checked if any driver or windows updates might have ■■■■■■ something.

I turned off Shadowplay and Win10 game dvr was already off, I killed any VR related programs in task manager such as steamvr and ovr. Even going as far to kill programs such as corsair utility engine and some razer stuff that I still had installed. But none of it even gave me a 1fps increase.

Something is screwing over unreal engine on my PC and I have no clue what :c.

Has anyone here had a similar experience? In what on earth was the one tiny obscure thing that caused it, cus I’m lost as to finding it.

Thanks for reading :slight_smile:

Following the track of “the light is the problem” I have a few questions about it:

How is your Light Importance Volumes around the level?

Your stationary lights, can you set them to static lights, just to test it?

About the materials, can you use a base material instead to check if you got any improvement.

Also, can you profile your scene rendering and post a picture of it statics? (GPU Profiling | Unreal Engine Documentation)

I have a Light importance Volume around the gameplay part of my level.

Instead of putting them on static and rebuilding for another hour I decided to turn shadows off on all lights, yet the performance was not impacted.

Here is the profile for scene rendering

While it may look like volumetric fog has a big impact, removing it only adds like 9fps at most. Nothing close to the 120fps I get in editor

Keep in mind the editor is a smaller window

lol, wow…I’ll disable steamVR in my project settings and I’m not even creating a VR game…thanks

No idea how you found this post, the game I was making here was released over a year ago and I’m currently a year into my latest project lmao.

I’ll leave this comment here for anyone else facing this issue because the solution was a dumb one, make sure SteamVR is disabled in your project settings. Even though no VR headset was plugged in just running SteamVR in the background caused the performance hit.