Download

AVolume failing in 4.23

Just after a sanity check. I have a class that descends from AVolume. In 4.22 if I placed it in the level it creates a box to indicate the size of the volume.

In 4.23 no box appears. If I set one manually in the brush, still no box appears.

No code changes in-between and I can’t see that ProceduralFoliageVolume and PostProcessVolume do anything in particular to show their box.

Does anyone know what’s up? Is this probably unintentional and worth a bug report?

  1. Your Volume should not be Blueprint - otherwise ue4 factories will not work and not shape will be created.
  2. " If I set one manually in the brush, still no box appears." - that is strange.

I am experimenting with custom volumes myself, and had similar bugs, but not sure what fixed them. Can you show your code?

I can tell that “do anything in particular to show their box” - that is true, all magic is happening in void UActorFactoryBoxVolume::PostSpawnActor( UObject* Asset, AActor* NewActor ) check if that function is called when you drag your volume to an editor.

If you want to make blueprintable volumes working - you need to override PostEditChangeProperty and PreEditChange

PS. Volumes are a real mess in UE4, I still didn’t get how to make them valid child objects.