Download

Avoiding the "multiple root" problem with FBX import?????

Hi everyone…first post. I’ve been having fun learning Blueprints, but I’ve hit a sticking point with trying to import my own FBX files from Softimage. I’ve had it working a few times, but mostly I get the “we only support a single root” error.

I have an idea of what that means, but when I adjust my rig to have one root, I still get the error. Does it mean all bones parented to one root bone? Or does it mean there’s a normal hierarchy? Can someone explain what the importer is looking for exactly?

Good to see you here! I don’t use Softimage and haven’t touch importing a skeletal mesh yet. It might be helpful if you post your question in the AnswerHub( https://answers.unrealengine.com/ ) along with a picture of your rig and its hierarchy or better yet a scene file or FBX so someone at Epic can look at it.

Not use if this is useful?: https://www.youtube.com/watch?v=Kvg-EABdkfQ

haha, I’ve actually followed that video – and I do have Species. So I tried it and it worked fine.

The problem is when I make a simple, non character based object that need to deform with bones. I tried looking at the structure of the Species rig, and what is making that import correctly, but it’s not clear yet. I’ll try the AnswerHub.

Yes, your rig needs to have a heirarchy such that they have one single root object that everything else branches off of. On a character it might be the pelvis bone.

OK, so passed a whole day to figure it out…

For what it’s worth with Softimage the solution is over simple… plot the global kine then remove neutral pose… DONE you now can import without the multiple root problem !!!