Avoid Retargeting Scale Changes

Hey, I’m trying to retarget animations between different skeletons. When I try to do it the animation bones’ scale comes out really overscaled. How can I fix this?

Is there any way I can avert the scale change issues?

Is there some documentation of exporting from Blender to UE4? I think it would go a long way. I found that for one when importing a animated mesh into UE4 the root bone has a scale of 100 despite in Blender it’s never more than 1; could this be a source of the problem? Any ideas how I would fix it?

Scale units in UE4 - percents. 1 is 100%.
Do you use translation retargeting options? All bones except root and hip use have translation from skeleton.

Right i know it’s 100x what it should be. I made some retargeting rigs but I think that was all @YuriNK , don’t think I messed with scale. Also I think it might be from importing like as you saw with the cone that was without any retargeting but the base bone still has a scale of 100X what it should be. Any ideas why?

Deselect ‘Convert Spaces to new Skeleton’ when regretting.