Download

AutomationTool was unable to run successfully

Hey,
I’m using a Mac Book Pro and I’m trying to run my level on my LG Android but I keep getting this error:
-------------------------------------------------------------------------------------------------------------------------------------LogPlayLevel: at BuildCookRun.ExecuteBuild () [0x00000] in :0 LogPlayLevel: at AutomationTool.BuildCommand.Execute () [0x00000] in :0 LogPlayLevel: at AutomationTool.Automation.Execute (System.Collections.Generic.List1 CommandsToExecute, Tools.DotNETCommon.CaselessDictionary.CaselessDictionary1 Commands) [0x00000] in :0 LogPlayLevel: at AutomationTool.Automation.Process (System.String] Arguments) [0x00000] in :0 LogPlayLevel: at AutomationTool.Program.MainProc (System.Object Param) [0x00000] in :0 LogPlayLevel: at AutomationTool.InternalUtils.RunSingleInstance (System.Func`2 Main, System.Object Param) [0x00000] in :0 LogPlayLevel: at AutomationTool.Program.Main () [0x00000] in :0 LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=5 (5) LogPlayLevel: Completed Launch On Stage: Build Task, Time: 1.522989 LogPlayLevel: RunUAT ERROR: PackagingResults:Error: Error Launch failed! Unknown Error -------------------------------------------------------------------------------------------------------------------------------------
I have tried the following:
Setting the Global Default Server Game Mode to the games current Game Mode.
Checking the SDK Config to make sure the locations are correct.
Manually Set the list of maps to include.
Set the Build Config to Development.
And none of these settings seemed to help.
Is there a way to ask the engine to be more specific as to what is going wrong?
Any help would be very appreciated!!! Thanks - Cohen

Also, could it be I installed something wrong like SDK, Java or did the overall process wrong? I couldn’t see how it could be causing this problem though as it only relates to how my Device connects to my computer.

I have even tried it in a empty level and it still gave me the error. Please help someone!

Does anyone have any ideas as to what is the problem? Thanks!

I would need to see the full log; there isn’t enough here to diagnose. It would be best to create an AnswerHub post.

Hi Chris,

Here is a link to the AnswerHub post :

https://answers.unrealengine.com/questions/657837/i-keep-getting-a-packaging-error-automationtool-wa.html#answer-668553

At the bottom of the thread, I did another post containing the error dialog.

Thank you! :slight_smile: