AutomationTool terminated with exception

Hello,

I am trying to build a game for win64 and the Shipping Config process is crushing with this error:
Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Stage Failed. Missing receipt ‘Testing-Win64-Shipping.target’. Check that this target has been built.

This file (Testing-Win64-Shipping.target) is missing from the directory after the crash

This happens with Shipping configuration. I can output with Development configuration - I was getting “cannot access directory” error in this mode but after changing folder access rights it worked eventually.

I have tried whats suggested on few other threads but without success. I have also tried doing this with fresh project with only few pieces of geometry and one light saved locally but the process always fails with the same error.

What am I doing wrong?

Thanks

I am fairly new with UE so any help is greatly appreciated.

Hi Misha,

There are a few trouble shooting steps to follow initially when having packaging issues:

1. Delete The following folders and then try repackaging

  • Intermediate
  • Saved
  • Config (deleting this folder will result in having to re-enter all values for your Editor and Project Settings. So make a copy somewhere safe!)

2. Disable Plugins

NEXT
Please provide the Log file by clearing your Ouput Log, package your project, then Cut and Paste from the newly generated Output Log into a text document and post.

After that we can move on from there! P.S. Make sure you get the entire log.

Thanks,

Ed Burgess

Hi Ed,

I have done what you’ve suggested.

If i do it with Window>Project launcher and than choose windows/shipping/by the book - I cant pass “Cook content for Win64” task. Please see txt logs attached. It always crashes there.

But if I do build via File>Package Project>Windows>Windows64 bit the process finishes successfully. I had same settings on both.

UATHelper: Packaging (Windows (64-bit)): Project.Package: ********** PACKAGE COMMAND STARTED **********
UATHelper: Packaging (Windows (64-bit)): Project.Package: ********** PACKAGE COMMAND COMPLETED **********
UATHelper: Packaging (Windows (64-bit)): Project.Archive: ********** ARCHIVE COMMAND STARTED **********
UATHelper: Packaging (Windows (64-bit)): Project.Archive: ********** ARCHIVE COMMAND COMPLETED **********
UATHelper: Packaging (Windows (64-bit)): Automation.Execute: BUILD SUCCESSFUL

I need to say that both ways were crushing before.

So what does this mean now?
Thank you!

Could you take a screenshot of your Project launcher so I can see all of the settings that you are using. I could also use a screenshot of your packaging settings just to make sure everything is okay.

Also could you use the same packaging profile(settings) for a blank project and see if you still get the crash.

Hi Ed,
I have managed to get the original file to buid correctly. I have deleted plugin (i had only substance installed) and have also deleted all the lights from the file. All content of /Config folder was untouched. The build process finishes without errors with those changes done.

The next thing i did was to start adding lights and at some stage process failed again. After deleting few lights that were created last and recreating and repositioning them the builds work fine again.

I am planning to reintroduce Substance plugin as I cant imagine working without it and see if that works.

I dont know if this rings any bells there but the problem seems to be the lighting. Does that make any sense? Is it possible that process fails due to the number of lights? I had only 10 lights on the level and few of them were dynamic ie had red cross on them.

I will leave it like this as I have deadline this friday and need to work on content and will keep posting if there is a problem again.
Thanks for your help!

Having 10 lights will not cause your project to fail packaging the issue lies elsewhere even if it is related to having lights in your scene. If you do start encountering this issue again. I will need information regarding:

  1. Your output log
  2. A screenshot of your packaging settings
  3. A screenshot of your custom launch parameters if you have any

Thanks,

OK, will do.
Thanks Ed!