AutomationTool error: No BuildPlatform found for Android

I’m attempting to update our project from a 4.13 source build to a 4.15 source build.

Everything has gone smoothly up until I want to use the automation tool to create an Android package. The tool was working as is under 4.13, but I get the following error when using the tool (with the same parameters) on 4.15:

Program.Main: ERROR: AutomationTool terminated with exception: ERROR: GetBuildPlatform: No BuildPlatform found for Android

The game runs fine from within the editor. I can even create an Android (ASTC) package from within the editor just fine. It’s only when I try building the package using the automation tool does it have problems.

I’ve tried debugging the automation tool and it appears that it is looking for an “[InstalledPlatforms]” section in the one of the config ini files. This section doesn’t appear anywhere in our ini files. It appears to be added during some automated geneation because it does show up in \Intermediate\Config\CoalescedSourceConfigs\Engine.ini for an empty template project. This does not show up in our project’s CoalescedSourceConfigs anywhere.

I’ve gone through everything I can think of, so some suggestions will be appreciated.

I am having this issue in 4.16.3 right now. Works when I cook and package in editor and from CMD but not when this is run via Jenkins. Same error.

Also having this problem from jenkins but not CMD- did you find a solution?

Run jenkins service with new account and reinstall necessary programs including visual studio, codeworks, etc. Also check path in advanced setting. It works for me!