Automatic rule skips animation in State Machine if the animation is reversed with playrate -1

In the Animation State Machine, when applying the automatic rule to transitions for animations that play in reverse (playrate -1), instead of waiting for the animation to finish, the State Machine automatically blends between the animation before the reversed one, and the one which follows it. So basically it skips the reversed animation entirely.

Steps to reproduce:

  1. Duplicate an animation and set the playrate to -1 (you might want to pick something a few seconds or longer just to make it extra obvious)
  2. Create an animation blueprint and add a state machine
  3. Add 3 States, First, Second, and Third
  4. In the First and Third State, add an animation which loops as usual (eg idle and hoving in air)
  5. In the Second State, add the reversed animation that you created in Step 1
  6. Set up a transition from the First to Second State (for example, an IsInAir boolean)
  7. For the transition from the Second to Third state, tick the “Automatic Rule Based on Sequence Player in State” tickbox
  8. Activate the transition (by ticking your boolean or whatever you set up in Step 6) and observe how the Second State is skipped
  9. Note how, if you replace the Second animation with the forward playing variant (playrate 1), the animation plays as expected and the Third State occurs after the Second State completes as expected.

Thanks very much for checking out this bug! It’s only little. :slight_smile:

1 Like


I have set up a project following the steps above, but am not seeing the same results. Could you post some screenshots of your Blueprints and State Machine, gif or video of your results, etc.? I can then take another look at the issue, any more info will be helpful.

-Thank you

Hi Ridley,

Thanks very much for getting back! Here are some screenshots of the state machine. The issue occurs on the “Come Down” animation, which is the reverse of the “Up To TipToes”.

Nothing is hooked up inside the transition node. It just uses the transition rule.


For the animation, I set the rate scale to -1. (It’s not called playrate, I guess.)


I can try to do a video for you as well, but can’t post it here due to confidentiality with my client. Is there a way to contact you directly?

Also, a colleague told me that FRAPS doesn’t seem to work with Unreal? That was a few months ago though, not sure if that’s still the case, but which software do you recommend for capturing footage (assuming you still need it)?

This issue still seems to exist in v 4.15 …Does anyone have a solution for this by any chance ?


You could use something like Open Broadcaster Software or even Snag It, however Snag It is not a free to use program. FRAPS is pretty popular, but it would come down to personal preference. Here is a link to one of the forum posts with some other recommendations for video capturing options. It’s an older post, but still has relevant recommendations. Also, if you need to send it to me directly you can do so here, but let me know on this thread when you do, so I can get back to you sooner.

-Thank you


Due to tracking purposes, I will be closing out this thread. If you have any other questions regarding the issue above, feel free to reopen the thread and I will get back to you.

-Thank you

Hi, can you please put the solution in this thread? The problem is the exact same as what OP has written, if you have an animation with a negative playrate, then the automatic transition rule skips it completely and goes to the next state if an outgoing transition rule is available. Thanks in advance.

Hi. The “Automatic Rule Based on Sequence Player in State” call occurs only after the transition animation has been completed. Does anyone know how to resolve this issue?