Download

Automatic pawn input?

Major wtf moment here.
I added a default pawn to an empty project.
there is no configured input.
the pawn moves around anyway any with AWSD and completely ignores any input you feed it…

Has anyone experienced this???

[USER=“3140864”]MostHost LA[/USER]
For me is a standard behaviour,
The default pawn works in empty project even without setting inputs

… however I would assume an axis plus add movement input overrides the direction?
In my case, it’s just not having it…

The default pawn has a floating movement component and processes input *automagically *(not only WASD but Q, E Space and Arrow Keys, too!). But you can override it via input consumption. Where are you handling the input?

If I do this in the Level Blueprint - which has higher input priority - and A here is set to consume input:

The default Pawn no longer moves when you press A.

I did not add / spawn a pawn. It’s in the blank template.

A not being an axis (aside from consume input) would not really cause the pawn to move though.

I solved my issue by going with a manual pawn without movement component and consume input × det o a > set actor location with sweep on tick.

for what its worth, my axis input for w/s was set on the pawn itself.
I also tried the controller BP using get controlled pawn as the target. Really not sure why the default would take over. Or where supposedly the check box to disable the default lives…
the docks say one exists. I did not see one however.

The whole point here was to demonstrate that you *can *process input before the default pawn gets to play with it; hence it’s actually set to 0,0,0 above - it would not move for sure, as expected. It was supposed to stop it.

If you create your own pawn, you can still use a movement component and process input.

Default pawn is inherited from C++ class that has input.