Automated build system errors (UE4Editor-X.dll missing)

Hi,

since yesterday we are not able to cook a build on our automated build system. I don’t have a clue whats wrong.
I think the important part is that (cook-2016.04.21-17.33.19.txt) :

LogInit:Warning: Incompatible or missing module: UE4Editor-ProjectX.dll
LogExit: Preparing to exit.

No binaries are checked in, everything is build by the build machine it self. Should the build compile a version of that dll? Because I can’t find any section in the log where he is doing that.

As workaround we do now a build step before the packaging/cooking to build the UE4Editor-ProjectX.dll:

C:/Program Files (x86)/Epic Games/4.11/Engine/Binaries/DotNET/UnrealBuildTool.exe ProjectX Development Win64 -project=“D:/ProjectX/ProjectX.uproject” -editorrecompile -progress -noubtmakefiles -NoHotReloadFromIDE -2015

Works fine for now.

Hey MartinSE-

I’m glad you were able to find a workaround for your problem, however I’m not sure I understand what was wrong originally. Can you provide more clarification of the issue you were having? Also, are you able to reproduce this issue in a new project? If so, can you provide step by step instructions for me to reproduce the issue locally?

Hi MartinSE,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Hi

I found this post after having the same issue myself. Here are some repro steps:

  1. Launch Unreal Engine 4.15.0.
  2. Create a new project (C++, Basic Code, No Starter Content).
  3. Close Unreal Editor and Visual Studio (saving the solution).
  4. From the project folder, run the command line similar to:RunUAT BuildCookRun -project="full_project_path_and_project_name.uproject" -noP4 -platform=Win64 -clientconfig=Development -serverconfig=Development -cook -allmaps -build -stage -pak -archive -archivedirectory="Output Directory"
  5. Result is successful build.
  6. Add gitignore from here: gitignore/UnrealEngine.gitignore at main · github/gitignore · GitHub
  7. Create new git repo in project folder.
  8. Commit all non-ignored files.
  9. Perform git clean, removing all untracked files.
  10. Again, run the command line similar to:RunUAT BuildCookRun -project="full_project_path_and_project_name.uproject" -noP4 -platform=Win64 -clientconfig=Development -serverconfig=Development -cook -allmaps -build -stage -pak -archive -archivedirectory="Output Directory"
  11. Result is failed build with error mentioned by OP.

I am currently having this issue, and I do not want to have to use the workaround mentioned by OP if possible.

Thanks.

Colin

Hi Colin,

Sorry for the delayed response. I ran through your repro steps and the second build in step 10 ended up completing successfully for me. Do you still see this issue in 4.15.3 or 4.16.1?

Tim

I finally found the workaround after trying a lot of things out. Note that if you change parameter below things might not work!

  1. First you need to do build:

    “path\to\BatchFiles\Build.bat” “MyUProjectEditor” Win64 Development -WarningsAsErrors “path\to\MyUProject.uproject”

  2. Call RunUAT:

    “path\to\BatchFiles\RunUAT.bat” BuildCookRun -project=“path\to\MyUProject.uproject” -noP4 -platform=Win64 -clientconfig=Development -cook -build -stage -pak -archive -archivedirectory="%OutPath%" -utf8output -compressed -prereqs

MartinSE: Your “work-around” saved me big time. I am not sure how this “bug” arises in the first place…