Download

Auto-save resets camera tracking

If I select “Actor to track” for my cameras and choose a recorded actor, Auto-save resets what I’ve changed. The same behavior occurs if I manually save the level. Saving sequencer changes has no effect. I’ve tried searching in the forum and with search engines with no luck. How can I keep cinematic camera tracking settings pointing to recorded actors from getting wiped out when level saves happen?

So, last night I closed UE4.25 and reopened it today. Now the saved character movement in the sequence has no animation for the character, though it translates fine. The Save icon associated with the sequencer seems to not save camera tracking, and a level save wipes every camera tracking out. Is there any way to exit UE4, re-enter UE4, and still have the cinematic settings and the animation for a cinematic sequence still intact, or is the intent that we should complete sequence recordings, reviews, camera cuts, and renderings without ever exiting the editor? What am I doing wrong here?

Well, I can’t even render. A pop-up asks whether I want to do a save of the changed tracking. If I say yes, it wipes out tracking and renders without it. If I say no, it wipes out tracking and renders without it. Does anybody successfully render a video with tracking active? How??

To get the bad behavior to stop, click on the “Add a keyframe” icon next to the camera “Player to track,” and its corresponding focus. Also add a keyframe for its Enable option. Now all work in the sequence and they survive a save game, whether manual or automatic.

what if you track, then use sequencer recorder to bake the camera animation to an animation clip
then just use that?