Auto-save has been permanently eating space on my C drive that I cannot locate

This computer has two hard drives.
C: SSD (for os)
D: HDD

I installed UE4 today to my D drive, but realized my C kept losing space. I began to suspect the ‘auto save’ function that had been going off every 10 minutes. I disabled this and capacity seemed to remain stable, until I opened another project wherein I had forgotten to turn off auto save. The C drive lost more space.

I know I’m down at least 2-3 gigs now but the thing is I can’t seem to find what is occupying this space to get it back.
The User/My Documents/ Unreal Projects folder is empty. I fear that having installed this on my D drive, and setting my project folder to a non-default location on the D drive as well -has lead to the auto-save function breaking. Possibly writing away my SSD space in a way that it then becomes inaccessible to free up again.

Note: I just did another test and turned auto save on. Went from 13.3 to 13.1 gigs now. This is definitely the auto save.

How can I go about recovering that portion of my SSD?

Tl;DR: Auto save is broke because my install and project files are on another drive. Auto save has been eating my SSD and sending that space to oblivion. Halp.

edit: Update

Is this possible related to or triggering the creation of ‘shadow copies’?

I ran admin cmd:
vssadmin delete shadows /for=c: /oldest

This removed the ‘oldest’ shadow copies by windows. It removed one file and brought me back to 14.4 gigs which was a number I recognized seeing earlier in the day.

Then I ran
vssadmin delete shadows /for=c: /all
Which removed 9 ‘recent’ files, that brought me back up to 20.2 gigs.

I can’t be sure that this is freeing the exact same memory that I’d lost before though.

is DerivedDataCache who is eating your space. You have to modify the BaseEngine.ini. I will post you a link about that in a few hours

Ahh. I’ll investigate that. So turning off Auto-save won’t fix it?

I’ll take any useful links you have as well. Thanks

Is not auto save…is just a ini file line which you have to modify. I’ll bet you also have problem with compiling material every time. Look to this and I promise you I will make a video tomorrow…- YouTube

Hey Nguruthos,

I’m curious to know if this fixed the issue for you. If it does, it’s very much a workaround. I’d still like to investigate with you so that we can resolve this issue on the engine side without having to work around the problem.

Thanks,
Matt W.

Look to this BaseEngine.ini and modify yours you have to put GAMEDIR to the lines 1839 and 1840 in this way your compiling cache date will go where you save your projets

I’m marking this answer as accepted for tracking purposes as we have not heard back from OP.

@OP, if you’d like to re-open, simply respond to this answer.

-Matt W.