Auto reimport no longer works (in 4.16 or 4.17)

auto reimport no longer works in 4.16 or 4.17. I just tried in a fresh install of 4.17 and the issue persists.

  1. here’s my project path : E:\Games\UT\testFirstPerson\testFirstPerson.uproject
  2. here’s my dir that i told unreal to auto reimport: E:\Games\UT\Source\
  3. here’s a test asset that i loaded, modified, and it’d fail to auto reimport : E:\Games\UT\Source\Meshes\Mapobjects\Test\earth.tga

i tried many things, including closing and restarting the editor and the auto reimport just couldn’t work. i’d have to manually reimport it. in another bug, a guy said he thinks auto reimport only works if the source file is WITHIN the path structure of the unreal project, but i’ve never tried to see if he’s right about that or not because in our projects, our source files would never be allowed to be in the ingame content folders. he mentioned it here : [4.16] Auto-Reimport not working with absolute filepath - Platform & Builds - Unreal Engine Forums