Download

auto generated lightmap UVs will not be updated by custom ones upon re-import

Hey guys n gals,

I have been working on a big set of unique models that have been imported into Unreal. I have chosen to test out the auto generated lightmap UVs to see if it would save me the daunting task of manually creating 400 lightmap uvs.
In the end the lighting was broken when using the auto generated lightmap UVs so I had to do this anyway. However after ticking off “Generate Lightmap UVS” and re-importing the mesh, it still displays the auto generated lightmap UV and not my custom made one.
Now I hope there is a way to fix this other than deleting the mesh and re-importing it that way (which loses its connection to the showcase map as well as the material assignment). I have looked on google for a bit but haven’t been able to find a conclusive answer. I hope that you can clarify this.

Thanks for reading and I am looking forward to your replies.

Dennis

Hey there!

After unchecking “generate lightmap uvs” you should have a button that says apply changes, or save changes in your mesh editor that should remove the engine generated uv set.

Thanks for your answer SE_JonF, but it does nothing. The only Save button I have is the Save this asset one. Once I uncheck the generate lightmap UV checkbox and click save, the lightmap is still there.

Here’s a photo demonstrating what I’m referring to. It should be on the right side of your mesh editor. Once you make a change to any of the settings there, the apply changes button should light up allowing you to click it.

applychanges.jpg

^This is the setting when you open a static mesh that you’ve imported. Meaning what you’d have to do to fix it would be to open each mesh in UE4 and edit the Build Settings for that mesh to disable auto generating the lightmap UV’s for it.

I never had thought to look there. I was looking in the import settings as the tickbox for the generate uv was there. I assumed it would undo it when re-importing the mesh.
I have already tried this and can confirm it works! Thanks for clearing this up!

Happy to help! =)

Hi, is there a way to apply this change to more than one asset at once? I have dozens of models with this problem. Thanks

Thank you, had the same problem! :slight_smile: