Download

Auto exposure?

How do I disable auto exposure / eye adaptation in UE5? In UE4 the tickbox in rendering settings worked but does not seem to do anything in 5

3 Likes

Add a Post-Process Volume on each levels of your game and set Min and Max Brightness to the same value (1 for bright scenes and around 0.5 for darker ones.

5 Likes

The auto exposure can be disabled in the project settings and in the viewport.

I have encountered the same issue. Maybe it’s a bug. @Darkin_Man solution seems to fix the problem for now.

1 Like

This is not necessarily a bug. There is a checkbox that must be disabled in the viewport.

image

1 Like

I am pretty sure this is a bug or at least a feature they forgot to fix before the early access release. Trying to disable the auto exposure in project settings does nothing at all, but disabling it in the viewport works.

Problem is if you’re working on a project where you don’t want auto exposure at all, there is no way of turning it off. Building the project and launching it, you’ll still have the auto exposure in the project even though it’s turned off since the viewport solution is only in the editor.

Doing the post process solution works, but adds to perfomance since the computer has to still calculate it. So in my eyes that is only a temporary solution until Epic has fixed this. Hopefully this will be patched soon.

7 Likes

I’ve encountered the same issue, the Auto-Exposure checkbox in the project settings does nothing, have to use a Post Process volume which I’m trying to avoid in my project entirely but until this gets fixed it’s the only solution.

Why would you do this?

There is no difference between having a post process volume in your scene or not. If there is no post process volume in your scene, it will revert to the default settings in Project Settings > Engine > Rendering.

You can change auto exposure settings or disable it in Project Settings > Engine > Rendering > Default Settings

I’ve got the same bug. Auto Exposure is unchecked in project render settings and I’m not using a post process volume at all.

2 Likes

Same Bug here. Auto exposure is unchecked in project settings. Game settings is checked in viewport, but I still get auto exposure in the viewport and in the game.

Currently using UE5-EA2 and can confirm that Auto-Exposure doesn’t turn off when you uncheck it in the Project Settings.

I have a temporary fix, I edited the min and max brightness on the exposure settings on my main character camera.
Clamping the values near to 1 seemed to work, and now i can tweak them as I see fit.

I hope this helps some of you.

1 Like
  1. Add a post process volume.
  2. In Post Processing Volume settings set it to infinite extent.
  3. Now under exposure set min and max exposure to 1.
    Depending on how bright your sun is you can use the exposure compensation.

Maybe you can even go to the character’s camera, scroll down to post processing and use the Exposure checkbox to set a default parameter.

1 Like

Looks like a bug. Disable in Project Settings should affect the entire Project. It was like that in UE4. Doesn’t work anymore.

EDIT: best result I found was using the post process volume idea. but even so the scene exposure in the play game is sligth different in the Play Window compared to the viewport window. Using a new empty project for the tests.

This worked for me although the lower the value the brighter the scene was, the higher the value the darker the scene was

I works for me only outdoor… now I am working indoors, it gives me auto exposure … and a very bad one
too…
Next to the ceiling its getting pitch black… even if auto exposure is in my opinion turned off and infinite bounds are set in post volume with the max and min brightness set to 1