Augmented Reality for UE4

Hello, you plugin is great!

I bought it with personal license (99$) and compile to windows — working great!
But it does not working in Android — write “webcamra init error”

Please, help!

P.S. build the whole engine from source 4.10 like you write here — (3. Android)
P.P.S. setup from «*.apk» on Anroid device


You will also need the .obb file.
Use the .bat file (located in your staging directory) for installing the app to your phone, or use the launch button from the editor for testing purposes.

I hope it helps!

Thanks for ansver.
I try that, but «webcam init error» is come back.

I need help


  1. I’m rebuild Unreal Engine — 4.9 and 4.10, like you write in instruction.
  2. create clear c++ project
  3. copy files
  4. compile the project
  5. installing app to my phone by using .bat file
  6. app is working, show me the butons, but «webcam init error»

But, then I launch project from Unreal Engine editor — it started to work on my phone well. (phone — micromax D303, android 4.4.2)

But, after recompile and setup to different device — it show me buttons and «webcam init error»

Pleas, help, I don’t understending…

So it appears that multi material is working on mobile.

To test it I made a couple simple materials that used constants for base color. Then I mapped the materials to their slots in the details view of my custom mesh. This worked on an and ipad air 2.

I think the build issue i was having before had to do with my source texture format perhaps? Not sure but I will looking more into it.

can anyone explain me how to create my own marker ? I tried to found but didnt found anything useful.

  1. Create your own markers following the original ARToolkit documentation:

NFT marker:

Fiducial marker:

  1. Copy the new files into YOUR_PROJECT/Content/ARToolkit/Data or DataNFT

  2. Add the new market to Markers or MarkerNFT enumerations (inside UE4 editor, content browser/blueprints)

  3. After the steps above you will be able to use your new markers!

when run this demo gives me oob error?

Which DEMO ?

but i mean that can i make a different marker, something like in unity. Any image of any size. Do you understand what i’m trying to say ?

Hey Adam,

I was looking at World’/Game/Maps/ARToolkitAdvanced.ARToolkitAdvanced’ scene in the commercial version of UnrealAR.

I’m trying to do something real simple to this scene. I wish to replace the Harley mesh with my own mesh and I want to be able to change textures or materials using your UI on my own mesh.

Do you think you could tell me how I can change this variable to point to my new mesh?


I figured out how to change the static mesh mapping AR_Actor_TouchBP

I also found in the MainUI Graph where each button is calling up a new texture for the Harley Mesh’s Material.

But I’m stuck there…I gotta be close to the solution…


Hey Adam,

So im trying to final a presentation i made with your plugin but the client prefers the orientation to have the home button to the right. This allows the camera on the ipad to be in a more natural position for AR viewing.

So I tried both options quoted above both individually and simultaneously and yet the camera sill is inverted for the ideal setting:

Project Settings -> IOS -> Orientation -> Support landscape right orientation (Checked)

Is their something else in the blueprint that may require the camera to be rotated 180 degrees landscape right is set? I guess another option would be for the UMG ui to not completely rotate but have each button just rotate 180 and stay in place…any thoughts on how to do either?

Here is an image of my mouse and wacom stylus defying gravity for ref.


I would try to mirror the camera image vertically. You can do it from code only.

In YOUR_PROJECT_PATH/Plugins/ARToolkitPlugin/Source/ARToolkitPlugin/Private/ARToolkitDevice.cpp

Find the following line:
NSString *vconf = [NSString stringWithFormat : @"%@ %@ %@ %@ %@", @"-format=BGRA", @"-fliph", @"-flipv", @"-preset=cif", @"-position=rear"];

change to:

NSString *vconf = [NSString stringWithFormat : @"%@ %@ %@ %@ %@", @"-format=BGRA", @"-fliph", @"-noflipv", @"-preset=cif", @"-position=rear"];

I think it will fix your issue!

I think you mean NFT markers. You can use any image of your choice as a marker.

I think you mean NFT markers. You can use any image of your choice as a marker.[/QUOTE]

Ok, thx again. I will try and write you back.

I tried this and still no results. But i might not be doing the right thing.

Here is what i tried:

  1. Found the c++ file @ PROJECT_PATH/Plugins/ARToolkitPlugin/Source/ARToolkitPlugin/Private/ARToolkitDevice.cpp
  2. Searched for “-flipv” and replaced with “-noflipv” in the above cpp file.
  3. Saved it.
  4. Returned to unreal and refresh the xcode project.
  5. Build and Launched on iPad.

Still didn’t work.

Do I need to make a brand new unreal project and copy the contents of the commercial zip again. Then change the cpp file then rebuild it? It seems their must be an easier way.


hi!!!please help me !!!i am from china ,i pay for your tool but i can not download !!!please help me !QQ图片20160424131809.png

is the re method to place AR behind a real object ?

I’ve sent you email with details. I hope it’s been already resolved by now.

Not with a normal webcamera. You need a depth sensor like the Kinect for this.

hii, i just wanna to try this amazing plugin. but unfortunately, i seems can’t open the demo project (i use unreal engine 4.9.2 and unreal engine 4.11.2)?? there is a warning that they can’t find the ARToolkit Module