Download

AudioCapture and Reverb won't work simultaneously (4.19.1)

I am trying to apply reverb to a mic input using the new AudioCapture component. As an experiment, I added an Audio Volume to my level (and cranked up the values on gain and delay). Jumping in the First-person test level I confirmed that the reverb worked. I added a cube to my scene and added an AudioCapture component to it. In the AudioCapture details I checked “Auto Activate” and unchecked “Send to Bus Only”. I hooked up an envelope follower to print mic amplitude to the screen for debugging. In a different test level I set up an AudioCapture just like this and it worked fine.

Adding the AudioCapture after the reverb, the envelope follower read 0.0 and “watch this value” in the blueprint confirmed that no input was received. The reverb effect still worked. Deleting the audio volume did not fix the zero input signal problem.

I deleted both and restarted the editor.

Adding AudioCapture to the level first, I do get signal from my mic. Adding the audio volume and reverb has no effect, even after deleting my actor containing the AudioCapture.

Restarting the editor without deleting either of them seems to be a coin flip which one works.

What am I doing wrong?

UE4.19.1
Windows 10
The microphone under test is set to my default recording device in Windows sound manager window.


-audiomixer

is added to my launch shortcut


AudioMixerModuleName=AudioMixerXAudio2

is added to my WindowsEngine.ini
Audio Capture, Sound Utilities and Synthesis plugins are enabled in my project settings.