Download

Audio Stops When Exiting Attenuation Falloff Distance

Hey fellow sound people,

I’ve got a problem with sounds stopping when the leave the falloff distance. I’ve made sure that the* “Allow Virtualized Sounds”* is checked, and that “Always Play” is check in the Master Bus. However, the sound still stops.
I’ve scoured the forums, Googled, and I did find a record of this happening in previous builds. The fix I’ve found that works is to override the attenuation, which is blah ok I’ll do it but I’d rather not. Is this a known issue with 4.19.2 that I missed? Is there an obvious fix that I’ve overlooked?

I’ve referenced the following documentation here, here, and here and as I said nothing from these topics have fixed the issue.

Any help pointing me in the right direction would be greatly appreciated.

Cheers!

Sorry for digging up an old thread but I also had this problem and found a solution, even thought it is not graceful.

Go to the sound file and scroll down to “Virtualization Mode” and change it from “Restart” to “PlayWhenSilent”. This made it work for me!

Had the same issue and for some reason only working with sound queues. I did not change anything in the sound queue just put the wav file in it, weird.

EDIT: This lloks to be an issue with looping not checked, you can use que or wav file as long as you have looping checked: Unreal Engine Issues and Bug Tracker (UE-53644)

It’s not a bug, you need to have “play when silent” enabled like @BumpLAD said above.